Bug 1080266 - SDDM is blank and KDE Plasma fail to load after latest upgrade to 5.12
SDDM is blank and KDE Plasma fail to load after latest upgrade to 5.12
Status: RESOLVED DUPLICATE of bug 1079465
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 10:09 UTC by Yunhe Guo
Modified: 2018-02-09 10:16 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yunhe Guo 2018-02-09 10:09:39 UTC
I upgraded to latest Tumbleweed snapshot with KDE 5.12 and reboot.

In SDDM screen, it is a white blank screen, with no mouse cursor. But you can still type your password and press Enter key to login.

In KDE Plasma workspace, the Plasma shell crash immediately and it is a black blank screen except a KWallet dialog asking password. Mouse cursor is available. Cannot run krunner or any application.
Comment 1 Yunhe Guo 2018-02-09 10:15:21 UTC
At least three other users in Telegram chat room have the same issue. Haven't found a work round except snapper rollback.
Comment 2 Wolfgang Bauer 2018-02-09 10:16:25 UTC
Delete /var/lib/sddm/.cache/ and your user's ~/.cache/.

It was a bug in Mesa, not Plasma 5.12 (which would not affect the login screen anyway).

*** This bug has been marked as a duplicate of bug 1079465 ***