Bug 1080244 - conflict of liberation-fonts and liberation2-fonts
conflict of liberation-fonts and liberation2-fonts
Status: RESOLVED FIXED
: 1071496 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stefan Knorr
E-mail List
[Leap-42.3-affected]
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 08:50 UTC by Stanislav Brabec
Modified: 2019-10-04 14:43 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Brabec 2018-02-09 08:50:59 UTC
When calling zypper dup, I got an upgrade problem:

Problem: suse-xsl-stylesheets-2.0.8-2.1.noarch requires liberation-fonts, but this requirement cannot be provided
  uninstallable providers: liberation-fonts-1.07.4-1.8.noarch[repo-oss]
 Solution 1: Following actions will be done:
  deinstallation of suse-xsl-stylesheets-2.0.8-1.4.noarch
  deinstallation of daps-2.4.0-3.5.noarch
 Solution 2: deinstallation of liberation2-fonts-2.00.1-7.8.noarch
 Solution 3: keep obsolete suse-xsl-stylesheets-2.0.8-1.4.noarch
 Solution 4: break suse-xsl-stylesheets-2.0.8-2.1.noarch by ignoring some of its dependencies

I tried 2, and it works, but I am not sure whether it is correct. It looks as downgrade.

In any case, it indicates missing Obsoletes or Provides in the spec file and blocks seamless Tumbleweed update.
Comment 1 Thomas Schraitle 2018-02-09 09:57:04 UTC
Hi Stanislav,

thanks for the report! :)

Stefan (now in CC) did the fix already in our Documentation:Tools repository 11 days ago (see https://build.opensuse.org/package/rdiff/Documentation:Tools/suse-xsl-stylesheets?linkrev=base&rev=116).

Factory contains already this fix. If I'm not mistaken, we can close this bug as fixed.

@Stefan, can you confirm this?
Comment 2 Thomas Schraitle 2018-02-09 09:59:07 UTC
Just for your information, here was the original pull request from Dominique:
https://github.com/openSUSE/suse-xsl/pull/362
Comment 3 Stefan Knorr 2018-02-09 12:01:49 UTC
I have opened an SR for the liberation-fonts package at:

  https://build.opensuse.org/request/show/574628


Dominique, would you mind having a look too? I was only 90% sure of what I was doing.
Comment 4 Dominique Leuenberger 2018-02-09 12:18:32 UTC
(In reply to Stefan Knorr from comment #3)
> I have opened an SR for the liberation-fonts package at:
> 
>   https://build.opensuse.org/request/show/574628
> 
> 
> Dominique, would you mind having a look too? I was only 90% sure of what I
> was doing.

This SR is an option, but not strictly nescessary - since suse-xsl-stylesheets with the dep changed to liberation-fonts is now in TW, I can drop liberation2-fonts there, which would result in an automatic (weak) obsoletes by openSUSE-release.

Your SR is not wront per se though, and can be used to further aid the migration 'back' to liberation-fonts'
Comment 5 Thomas Schraitle 2018-02-12 15:35:09 UTC
*** Bug 1071496 has been marked as a duplicate of this bug. ***
Comment 7 Tony Mechelynck 2018-04-25 22:14:24 UTC
I _think_ the problem I get on openSUSE Leap 42.3 when trying to install Update-Test patch 8029-1.noarch is related to this bug but the zypper report (below) is more verbose. I'll temporarily cancel the update while I investigate which course of action seems best.

linux-2iyu:~ # (zypper patch --with-update || echo 'exit status' $? ; date ) 2>&1 |tee -a ~/zypper.log
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libreoffice-6.0.3.2-18.1.x86_64 requires liberation-fonts, but this requirement cannot be provided
  uninstallable providers: liberation-fonts-1.07.2-6.3.noarch[DVD]
                   liberation-fonts-1.07.2-6.3.noarch[OSS]
 Solution 1: Following actions will be done:
  deinstallation of libreoffice-5.4.5.1-15.1.x86_64
  deinstallation of libreofficekit-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-writer-extensions-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-writer-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-pyuno-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-math-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-l10n-en-5.4.5.1-15.1.noarch
  deinstallation of libreoffice-kde4-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-impress-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-gtk3-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-gnome-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-draw-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-calc-extensions-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-calc-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-base-drivers-mysql-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-base-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-mailmerge-5.4.5.1-15.1.x86_64
  deinstallation of libreoffice-filters-optional-5.4.5.1-15.1.x86_64
  deinstallation of unoconv-0.7-12.1.noarch
 Solution 2: Following actions will be done:
  deinstallation of liberation2-fonts-2.00.1-12.1.noarch
  deinstallation of suse-xsl-stylesheets-2.0.7.2-4.1.noarch
  deinstallation of daps-2.4.0-1.3.noarch
 Solution 3: do not install patch:8029-1.noarch
 Solution 4: break libreoffice-6.0.3.2-18.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/c] (c):
Comment 8 Tony Mechelynck 2018-04-25 22:30:53 UTC
I may be wrong but it seems to me that (with this patch) unoconv and suse-xsl-stylesheets cannot be installed together at the moment on Leap 42.3.
Comment 9 Tony Mechelynck 2018-04-25 23:26:41 UTC
My temporary solution (to avoid choosing between unoconv and suse-xsl-stylesheets, and still retain some consistency across libreoffice packages) was to use "zypper up" with package names, and install everything that could be installed with no conflicts with the exception of libreoffice-branding-upstream (the only unconflicting package whose name started with "libreoffice").
Comment 10 Thomas Schraitle 2018-04-26 08:41:58 UTC
(In reply to Tony Mechelynck from comment #8)
> I may be wrong but it seems to me that (with this patch) unoconv and
> suse-xsl-stylesheets cannot be installed together at the moment on Leap 42.3.

I think that is a side effect related to the change in bsc#1044521. I don't think this has anything to do with the unoconv package. There aren't files or requirements which conflicts with suse-xsl-stylesheets.

@sknorr: can you confirm this?
Comment 11 Stefan Knorr 2018-04-26 11:13:38 UTC
I think this issue exists because LibO 6.0 was packaged with a dependency on liberation-fonts while 5.4 had a dependency on liberation2-fonts. Essentially, you can now either:
* update LibO and delete suse-xsl-stylesheets or
* keep the old version of LibO and also keep the stylesheets

I am not quite sure how to resolve that. I could update the stylesheets to require liberation-fonts again, but then you would be unable to keep your old LibO enabled.

Or I could submit the changes from https://build.opensuse.org/request/show/574628 to Leap 42.3 as well but I am unsure what will happen then, as both liberation-fonts and liberation2-fonts are still available in 42.3.

Tomas, as the most likely packager of LibO -- do you have ideas?
Comment 12 Tony Mechelynck 2018-04-26 12:59:56 UTC
(In reply to Stefan Knorr from comment #11)
> I think this issue exists because LibO 6.0 was packaged with a dependency on
> liberation-fonts while 5.4 had a dependency on liberation2-fonts.
> Essentially, you can now either:
> * update LibO and delete suse-xsl-stylesheets or
> * keep the old version of LibO and also keep the stylesheets
> 
> I am not quite sure how to resolve that. I could update the stylesheets to
> require liberation-fonts again, but then you would be unable to keep your
> old LibO enabled.

As a user (not a developer) I can do without the "old" libreoffice if I can get the "new" one. Especially if it installs with no conflict.

This would IIUC (or would it?) reverse the fix in boo#1044521 (sorry, let's be installation-agnostic, in bug #1044521) but it's not for me to decide if "the way of the future" is from liberation-fonts to liberation2-fonts or vice-versa.
> 
> Or I could submit the changes from
> https://build.opensuse.org/request/show/574628 to Leap 42.3 as well but I am
> unsure what will happen then, as both liberation-fonts and liberation2-fonts
> are still available in 42.3.

Again as a user and not a developer I would feel ill at ease if I knew that a long-run divergence is creeping between the packages in Tumbleweed and in Leap. Maybe (but it isn't for me to decide) this is the right time to decide which one of liberation-fonts and liberation2-fonts is the best for both Tumbleweed and Leap, and do away with the other after making sure that the change won't create conflicts in other packages. However, this might be too big a change for 42.3, and it may or may not be too late for Leap 15.0 ("package freeze April 24, final submission deadline May 14, release end of May").
> 
> Tomas, as the most likely packager of LibO -- do you have ideas?
Comment 13 Thomas Schraitle 2018-04-26 13:26:29 UTC
(In reply to Tony Mechelynck from comment #12)
> 
> However, this might be too
> big a change for 42.3, and it may or may not be too late for Leap 15.0
> ("package freeze April 24, final submission deadline May 14, release end of
> May").

As far as I know, the change is already in Factory and as such also in Leap 15.0.
Comment 14 Jon Stephens 2018-04-28 08:58:10 UTC
Also hitting this on Leap 42.3. suse-xsl-stylesheets-2.0.7.2-4.1.noarch and daps-2.4.0-1.3.noarch both require liberation2-fonts. Latest update for LibreOffice requires liberation-fonts.
Comment 15 Carlos Robinson 2018-04-28 10:39:38 UTC
I have that problem on Leap 42.3

#### YaST2 conflicts list - generated 2018-04-27 13:57:03 ####

libreoffice-6.0.3.2-18.1.x86_64 requires liberation-fonts, but this requirement cannot be provided
uninstallable providers: liberation-fonts-1.07.2-6.3.noarch[download.opensuse.org-oss]
    [ ] Following actions will be done:
deinstallation of libreoffice-5.4.5.1-15.1.x86_64
deinstallation of libreofficekit-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-writer-extensions-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-writer-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-pyuno-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-math-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-l10n-es-5.4.5.1-15.1.noarch
deinstallation of libreoffice-l10n-en-5.4.5.1-15.1.noarch
deinstallation of libreoffice-kde4-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-impress-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-gtk3-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-gnome-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-draw-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-calc-extensions-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-calc-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-base-drivers-mysql-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-base-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-mailmerge-5.4.5.1-15.1.x86_64
deinstallation of libreoffice-filters-optional-5.4.5.1-15.1.x86_64
deinstallation of unoconv-0.7-12.1.noarch
    [ ] Following actions will be done:
deinstallation of liberation2-fonts-2.00.1-12.1.noarch
deinstallation of suse-xsl-stylesheets-2.0.7.2-4.1.noarch
deinstallation of daps-2.4.0-1.3.noarch
    [ ] do not install patch:openSUSE-2018-402-1.noarch

    [ ] break libreoffice-6.0.3.2-18.1.x86_64 by ignoring some of its dependencies



#### YaST2 conflicts list END ###

Telcontar:~ # rpm -qa | grep -i liberation
liberation2-fonts-2.00.1-12.1.noarch
Telcontar:~ # 


What is the correct action above, as user, to get libreoffice updated?
Comment 16 Thomas Schraitle 2018-05-03 13:11:48 UTC
according to bsc#1044521, this seems to be fixed, so I'll close this bug now. Just reopen it if I'm mistaken. :)

*** This bug has been marked as a duplicate of bug 1044521 ***
Comment 17 Tony Mechelynck 2018-05-03 13:53:04 UTC
(In reply to Thomas Schraitle from comment #16)
> according to bsc#1044521, this seems to be fixed, so I'll close this bug
> now. Just reopen it if I'm mistaken. :)
> 
> *** This bug has been marked as a duplicate of bug 1044521 ***

Bug 1044521 was VERIFIED FIXED on 2017-06-18 while this bug was reported on 2018-02-09. IMHO it cannot be a duplicate of a bug fixed several months before it was reported, especially since this bug was reported for Tumbleweed then seen also (comment #7) on 42.3
Comment 18 Tony Mechelynck 2018-05-03 13:57:59 UTC
P.S. Bug 1044521 was fixed temporarily for 42.2 but the problem still exists on later releases.
Comment 19 Swamp Workflow Management 2018-05-25 16:10:05 UTC
This is an autogenerated message for OBS integration:
This bug (1080244) was mentioned in
https://build.opensuse.org/request/show/612274 42.3 / suse-xsl-stylesheets
Comment 21 Stefan Knorr 2018-05-30 17:22:21 UTC
Resolving fixed, maintenance update for 42.3 should go out soon.
Comment 22 Tony Mechelynck 2018-05-30 20:20:23 UTC
I had this problem on openSUSE Leap 42.3, but I won't be able to VERIFY the fix because Sunday (27 May) I upgraded to the newly released 15.0, where LibreOffice and suse-xsl-stylesheets both require liberation-fonts and not the conflicting liberation2-fonts.
Comment 23 Swamp Workflow Management 2018-06-04 16:07:09 UTC
openSUSE-RU-2018:1495-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1080244
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    suse-xsl-stylesheets-2.0.7.2-5.3.1
Comment 24 Swamp Workflow Management 2018-11-02 23:09:55 UTC
SUSE-RU-2018:3612-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1080244
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    suse-xsl-stylesheets-2.0.7.2-14.6.35
Comment 25 Swamp Workflow Management 2019-10-04 13:12:59 UTC
SUSE-RU-2018:3612-2: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1080244
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    suse-xsl-stylesheets-2.0.7.2-14.6.35

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.