Bug 1080045 - Graphical login shows white screen after upgrade
Graphical login shows white screen after upgrade
Status: RESOLVED DUPLICATE of bug 1079465
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-08 11:24 UTC by Josef Zlomek
Modified: 2018-02-08 12:15 UTC (History)
1 user (show)

See Also:
Found By: Customer
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Log when graphical login shows a blank screen (68.45 KB, text/x-log)
2018-02-08 11:24 UTC, Josef Zlomek
Details
Log for "startx -- :1" executed by root logged in in a text console (91.23 KB, text/x-log)
2018-02-08 11:25 UTC, Josef Zlomek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Zlomek 2018-02-08 11:24:13 UTC
Created attachment 759391 [details]
Log when graphical login shows a blank screen

Today, I have updated packages using the "Software Updates" tool in the KDE panel.
As kernel was also updated, I have restarted the machine.

After the restart, the graphical login shows a blank screen.
The log Xorg.0.log is attached for this instance of X server.
There is an error "systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration"

Surprisingly, when I logged in as root in a text console and started "startx -- :1",
the graphical interface was started without a problem.
The above mentioned error is not in the log Xorg.1.log for this instance of X server.
Comment 1 Josef Zlomek 2018-02-08 11:25:50 UTC
Created attachment 759392 [details]
Log for "startx -- :1" executed by root logged in in a text console
Comment 2 Josef Zlomek 2018-02-08 11:29:56 UTC
I think that the bug report 1080007 is the same problem.
Comment 3 Stefan Dirsch 2018-02-08 11:39:16 UTC
dup

*** This bug has been marked as a duplicate of bug 1079465 ***
Comment 4 Josef Zlomek 2018-02-08 11:55:50 UTC
Is the fix for bug 1079465 already in the update repository?
My machine is updated to the most recent packages and it still does not work.

Maybe this really is a different problem.
Comment 5 Stefan Dirsch 2018-02-08 12:02:12 UTC
(In reply to Josef Zlomek from comment #4)
> Is the fix for bug 1079465 already in the update repository?
> My machine is updated to the most recent packages and it still does not work.
> 
> Maybe this really is a different problem.

No. Check also instructions in https://bugzilla.opensuse.org/show_bug.cgi?id=1079465#c4

Mesa changelog needs to include this change:

Tue Feb  6 08:42:03 UTC 2018 - msrb@suse.com

- u_mesa-st-shader_cache-restore-num_tgsi_tokens-when-loading.patch
  * Fix crash when loading shader. (bnc#1079465)
Comment 6 Josef Zlomek 2018-02-08 12:15:06 UTC
Thank you, clearing the cache ~/.cache and /var/lib/sddm/.cache solved the problem!