Bug 1080037 - "yast2 lan list" warns about closing STDIN
"yast2 lan list" warns about closing STDIN
Status: RESOLVED DUPLICATE of bug 966042
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other openSUSE 42.2
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-08 10:49 UTC by Christian Boltz
Modified: 2018-04-26 14:50 UTC (History)
3 users (show)

See Also:
Found By: Beta-Customer
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
schubi: needinfo? (suse-beta)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Boltz 2018-02-08 10:49:10 UTC
The output says it all:

# yast2 lan list
id      name,                   bootproto
0       Wireless 7260, Not configured
1       RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller, Not configured
Warning: unable to close filehandle properly: Bad file descriptor, <STDIN> line
        5 during global destruction (#1)
    (S io) There were errors during the implicit close() done on a filehandle
    when its reference count reached zero while it was still open, e.g.:
    
        {
            open my $fh, '>', $file  or die "open: '$file': $!\n";
            print $fh $data or die "print: $!";
        } # implicit close here
    
    Because various errors may only be detected by close() (e.g. buffering could
    allow the print in this example to return true even when the disk is full),
    it is dangerous to ignore its result.  So when it happens implicitly, perl
    will signal errors by warning.
    
    Prior to version 5.22.0, perl ignored such errors, so the common idiom shown
    above was liable to cause silent data loss.


I see this with yast2-network-3.3.6-1.1.noarch (sorry, I didn't have time for tumbleweed updates in the last weeks)

This bug is probably not depending on the hardware or config, therefore not attaching y2logs. If you need them nevertheless, please tell me.
Comment 1 Stefan Schubert 2018-02-16 09:00:05 UTC
(In reply to Christian Boltz from comment #0)
> I see this with yast2-network-3.3.6-1.1.noarch (sorry, I didn't have time
> for tumbleweed updates in the last weeks)
I have tested the current 4.0.14 version and it has worked.
Maybe you should give an update a try ? :-)
> 
> This bug is probably not depending on the hardware or config, therefore not
> attaching y2logs. If you need them nevertheless, please tell me.
If you still an error please attach the logs. Thanks !
Comment 2 Knut Alejandro Anderssen González 2018-04-26 14:50:20 UTC
Seems to be a duplicate of https://bugzilla.suse.com/show_bug.cgi?id=966042, so closing it by now. Feel free to reopen it if I'm wrong.

*** This bug has been marked as a duplicate of bug 966042 ***