Bug 1079991 - `zypper ps -s` reports that "running processes use deleted files" immediately after start
`zypper ps -s` reports that "running processes use deleted files" immediately...
Status: RESOLVED FIXED
: 866300 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: libzypp
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-08 07:45 UTC by Michal Nowak
Modified: 2018-10-18 16:17 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
/tmp/bsc1079991.lsof (3.83 KB, text/plain)
2018-02-11 09:27 UTC, Michal Nowak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Nowak 2018-02-08 07:45:32 UTC
Running latest Tumbleweed. When I start the OS and run `zypper ps -s`, I see:

"""
The following running processes use deleted files:

PID  | PPID | UID | User | Command              | Service
-----+------+-----+------+----------------------+--------
2532 | 2502 | 463 | gdm  | gnome-session-binary |        
2538 | 2494 | 463 | gdm  | at-spi-bus-launcher  |        
2555 | 2532 | 463 | gdm  | gnome-shell          |        
2626 | 2623 | 463 | gdm  | ibus-dconf           |        
2650 | 2532 | 463 | gdm  | gsd-a11y-keyboard    |        
2653 | 2532 | 463 | gdm  | gsd-a11y-settings    |        
2669 | 2532 | 463 | gdm  | gsd-keyboard         |        
2695 | 2532 | 463 | gdm  | gsd-sharing          |        
2699 | 2532 | 463 | gdm  | gsd-smartcard        |        
2700 | 2532 | 463 | gdm  | gsd-sound            |        

You may wish to restart these processes.
See 'man zypper' for information about the meaning of values in the above table.
"""

It may be technically true, but the 'ps -s' check when run after any zypper installation/update process always reports that something might be restarted. Such a check looks a bit superfluous. Older bug #1046417 on the same topic.
Comment 1 Michael Andres 2018-02-08 11:28:02 UTC
> lsof -n -FpcuLRftkn >/tmp/bsc1079991.lsof

Please run the above command (while zypper is showing the false positives) and attach the tmp file. We'll try to enhance the filter.
Comment 2 Michael Andres 2018-02-08 12:06:20 UTC
> lsof -n -FpcuLRftkn0 >/tmp/bsc1079991.lsof

If possible run it with the additional `-0`. The binary output is easier to consume for us.
Comment 3 Michal Nowak 2018-02-08 17:43:42 UTC
(In reply to Michael Andres from comment #2)
> lsof -n -FpcuLRftkn0 >/tmp/bsc1079991.lsof

Is it really the right command? Size of the output is close to 10 MB, records paths to a lot of files on my system, including some in /home...
Comment 4 Michael Andres 2018-02-08 18:31:38 UTC
I'm sorry Michal. 

It's actually the command that zypper executes, but you are right, it produces far more data about your system than we need. Sorry again, that I did not keep this in mind. 

- If you call `zypper ps` (without -s) it also shows the list of files. You should be able to use this command to extract the list of files:
> zypper ps | sed -n 's/^[^P].*| \([^ ]*\).*/\1/p' | sort -u > /tmp/lsof_filter_files

- We just need the info for these files (or the subset you feel comfortable with):
> lsof -n -FpcuLRftkn0 | tr '\0' '@' | grep -f /tmp/lsof_filter_files > /tmp/bsc1079991.lsof
Comment 5 Michal Nowak 2018-02-11 09:27:20 UTC
Created attachment 759718 [details]
/tmp/bsc1079991.lsof

No problem at all Michael. See the file attached.
Comment 6 Michael Andres 2018-02-28 08:08:39 UTC
*** Bug 866300 has been marked as a duplicate of this bug. ***
Comment 7 Michael Andres 2018-02-28 08:49:32 UTC
*** Bug 866300 has been marked as a duplicate of this bug. ***
Comment 8 Michael Andres 2018-02-28 09:02:29 UTC
*** Bug 866300 has been marked as a duplicate of this bug. ***
Comment 9 Benjamin Zeller 2018-03-02 08:42:17 UTC
Fixed in libzypp versions:
TW/SLE-15 16.17.11, SLE-12-SP3/SP2  16.17.11
Comment 10 Swamp Workflow Management 2018-04-25 16:10:17 UTC
SUSE-RU-2018:1073-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1075978,1077635,1079991,1082318,1086602
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    libsolv-0.6.34-2.11.2, libzypp-16.17.12-2.28.2
SUSE Linux Enterprise Server 12-SP3 (src):    libsolv-0.6.34-2.11.2, libzypp-16.17.12-2.28.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    libsolv-0.6.34-2.11.2, libzypp-16.17.12-2.28.2
SUSE CaaS Platform ALL (src):    libsolv-0.6.34-2.11.2, libzypp-16.17.12-2.28.2
Comment 11 Swamp Workflow Management 2018-04-26 19:12:24 UTC
openSUSE-RU-2018:1090-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1075978,1077635,1079991,1082318,1086602
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    libsolv-0.6.34-9.1, libzypp-16.17.12-24.1
Comment 12 Swamp Workflow Management 2018-05-14 13:13:20 UTC
SUSE-RU-2018:1281-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1075978,1077635,1079991,1082318,1086602
CVE References: 
Sources used:
SUSE OpenStack Cloud 7 (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4
SUSE Enterprise Storage 4 (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4
OpenStack Cloud Magnum Orchestration 7 (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4
Comment 13 Swamp Workflow Management 2018-10-18 16:17:37 UTC
SUSE-RU-2018:1281-2: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1075978,1077635,1079991,1082318,1086602
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    libsolv-0.6.34-2.27.16.3, libzypp-16.17.12-27.47.4