Bug 1079931 - login leads to white screen after "Starting X Display manager"
login leads to white screen after "Starting X Display manager"
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
PC openSUSE Factory
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 21:45 UTC by Matthew Mah
Modified: 2018-02-09 23:53 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Mah 2018-02-07 21:45:06 UTC
After updating using the Software Updates widget, on a Lenovo T420 and a Lenovo T460s, I can no longer boot into a usable KDE desktop environment. From the boot menu, selecting any kernel version (4.15? and 4.14?) and either recovery or not, leads to a white screen with cursor. The last console message I can read before the white screen is "Starting X Display manager". 

With a fresh install using Tumbleweed from 2017-11-08 on the T460s, upgrading using zypper dist-upgrade results in a KDE desktop that is missing the taskbar, and the shortct ALT-F1, which normally brings up the application menu, does nothing. 

I need both these computers in a usable state, so if there is any information I can provide quickly before reinstalling, let me know.
Comment 1 Joop Boonen 2018-02-08 22:48:54 UTC
I have the same issue, since the last Mesa Update.
ssdm shows a white screen. Plasma doesn't show the menu bar any more.
When using kdm this issue doesn't appear, all other window managers don't show this issue. Gnome, Windows Maker, Lxqt.

Systems with i5-5200U and i5-2520M.
Haven't tested it on a dedicated GPU or a AMD IGP yet. So I don't know this is also an issue these systems.
Comment 2 Stefan Dirsch 2018-02-08 23:32:49 UTC
dup

*** This bug has been marked as a duplicate of bug 1079465 ***
Comment 3 Joop Boonen 2018-02-09 19:20:56 UTC
https://bugzilla.opensuse.org/show_bug.cgi?id=1079465 Didn't solve this issue, it caused this issue.

Mesa-18.0.0-187.1.x86_64 is one of the packages.  I.e. the problem still exists.
Comment 4 Joop Boonen 2018-02-09 20:09:31 UTC
Mesa-18.0.0-791.1 (X11:/XOrg) resolved this issue. 

* Fri Feb 02 2018 sndirsch@suse.com
- Update to 18.0.0-rc3
  * includes significant improvements for OpenGL and Vulkan support
    and performance.
- supersedes U_intel-Add-more-Coffee-Lake-PCI-IDs.patch

I've just tested it.
Comment 6 Stefan Dirsch 2018-02-09 23:53:23 UTC
Please read https://bugzilla.opensuse.org/show_bug.cgi?id=1079465#c4 carefully.