Bug 1079923 - konsole backspace
konsole backspace
Status: RESOLVED DUPLICATE of bug 1079543
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 20:50 UTC by Jozsef Darabos
Modified: 2018-02-07 21:48 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
flying prompt (80.05 KB, image/png)
2018-02-07 21:26 UTC, Jozsef Darabos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jozsef Darabos 2018-02-07 20:50:35 UTC
hi,

its happends after update. 
when I try put some commands in konsole, and a wrote something wrong, then I will make a correction with the backspace key the cursor not clear the characters, its moving to right. when I push the enter key I can get the corrected command, but I not understand while the cursor not moving left width the backspace key.
I did'nt changed anything it the settings.
Comment 1 Wolfgang Bauer 2018-02-07 21:11:50 UTC
Does it happen unconditionally, or just with certain applications run in konsole?

Does running "export TERM=xterm" or changing the TERM setting in Konsole's settings help?

Sounds very much like the latest regression in ncurses...

See also bug 1079543
Comment 2 Wolfgang Bauer 2018-02-07 21:14:45 UTC
(In reply to Wolfgang Bauer from comment #1)
> Sounds very much like the latest regression in ncurses...

To be clear, not really a regression in ncurses, but caused by changes in ncurses.
Comment 3 Jozsef Darabos 2018-02-07 21:26:19 UTC
Created attachment 759326 [details]
flying prompt
Comment 4 Jozsef Darabos 2018-02-07 21:27:12 UTC
My TERM is xterm-256color. I think it was the default.
It happends width the bash prompt for example.
Other I did'nt tried. 
If I try to resize the Konsole window my prompt is "flies". I hope is the best expression :)
Check the screenshot. I just resized few pixels.
Comment 5 Jozsef Darabos 2018-02-07 21:39:13 UTC
(In reply to Wolfgang Bauer from comment #1)
> Does it happen unconditionally, or just with certain applications run in
> konsole?
> 
> Does running "export TERM=xterm" or changing the TERM setting in Konsole's
> settings help?
> 
> Sounds very much like the latest regression in ncurses...
> 
> See also bug 1079543

hoi,
thanks man! I changed the environment settings to xterm and its working again.
Thanks a LOT!
Comment 6 Wolfgang Bauer 2018-02-07 21:48:42 UTC
(In reply to Jozsef Darabos from comment #5)
> thanks man! I changed the environment settings to xterm and its working
> again.
> Thanks a LOT!

Fine.

But it's rather a duplicate then, not FIXED...

*** This bug has been marked as a duplicate of bug 1079543 ***