Bug 1079863 - Mesa related packages in Tumbleweed-Update are lethal!
Mesa related packages in Tumbleweed-Update are lethal!
Status: RESOLVED DUPLICATE of bug 1079465
: 1079891 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 15:07 UTC by Tamás Németh
Modified: 2018-02-08 07:55 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2018-02-07 15:07:46 UTC
Mesa related packages from http://download.opensuse.org/update/tumbleweed/ with the version number 18.0.0-187.1 made my notebook unusable! As soon as X.org started, the displays changed to empty and white. Please remove these packages ASAP! I could hardly revert to 18.0.0-185.1
Comment 1 Stefan Dirsch 2018-02-07 15:41:47 UTC
I guess that's another duplicate of boo#1079465.
Comment 2 Stefan Dirsch 2018-02-07 15:43:37 UTC
Please check https://bugzilla.opensuse.org/show_bug.cgi?id=1079465#c3
Comment 3 Michal Srb 2018-02-07 15:45:35 UTC
With 18.0.0-187.1 it should be already fixed, but you most likely have damaged shader in cache saved by 18.0.0-185.1.

Delete ~/.cache and /var/lib/sddm/.cache directories.
Comment 4 Tamás Németh 2018-02-07 15:46:05 UTC
(In reply to Stefan Dirsch from comment #1)
> I guess that's another duplicate of boo#1079465.

Probably not. The mentioned Mesa versions appeared just today in Tumbleweed-update. Anyway, Tumbleweed-update shouldn't contain "real" packages, only some test and meta packages, AFAIK! Putting these real packages into this repository was probably a mistake.
Comment 5 Tamás Németh 2018-02-07 15:50:52 UTC
(In reply to Stefan Dirsch from comment #1)
> I guess that's another duplicate of boo#1079465.

I mean putting these real packages into this repository was probably an accident. BTW, see #c4
Comment 6 Stefan Dirsch 2018-02-07 15:55:58 UTC
Not sure what you would like to tell me. I can only ask you to give the latest Mesa packages with the fix a try and remove the cache manually as suggested in comment #3. Michal and me are pretty sure it's just a duplicate.
Comment 7 Tamás Németh 2018-02-07 15:57:32 UTC
OK, I'll try. One moment please...
Comment 8 Tamás Németh 2018-02-07 16:14:54 UTC
(In reply to Stefan Dirsch from comment #6)
> Not sure what you would like to tell me. I can only ask you to give the
> latest Mesa packages with the fix a try and remove the cache manually as
> suggested in comment #3. Michal and me are pretty sure it's just a duplicate.

OK, deleting the cache files solved the problem. However, I think the new packages probably should include some post/pre-install scripts to delete the packages, because this way they will render so much computers practically unusable.
Comment 9 Aleksey Kontsevich 2018-02-07 18:03:23 UTC
Seems this bug related: https://bugzilla.suse.com/show_bug.cgi?id=1079891
Comment 10 Aleksey Kontsevich 2018-02-07 18:14:17 UTC
*** Bug 1079891 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Dirsch 2018-02-07 23:59:17 UTC
Closing as dup.

(In reply to Tamás Németh from comment #8)
> OK, deleting the cache files solved the problem. However, I think the new
> packages probably should include some post/pre-install scripts to delete the
> packages, because this way they will render so much computers practically
> unusable.

I guess you're talking about removing *cache* files. I expect more harm than benefit when trying this. Seriously. And you cannot remove files in $HOME of a network drive anyway.

*** This bug has been marked as a duplicate of bug 1079465 ***
Comment 12 Tamás Németh 2018-02-08 07:55:10 UTC
(In reply to Stefan Dirsch from comment #11)
> Closing as dup.
> 
> (In reply to Tamás Németh from comment #8)
> > OK, deleting the cache files solved the problem. However, I think the new
> > packages probably should include some post/pre-install scripts to delete the
> > packages, because this way they will render so much computers practically
> > unusable.
> 
> I guess you're talking about removing *cache* files. I expect more harm than
> benefit when trying this. Seriously. And you cannot remove files in $HOME of
> a network drive anyway.
> 
> *** This bug has been marked as a duplicate of bug 1079465 ***

I think, you're right. Thank you for your effort.