Bug 1079837 - [glibc2.27] guile fails to build
[glibc2.27] guile fails to build
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Peter Simons
E-mail List
:
Depends on:
Blocks: 1079753
  Show dependency treegraph
 
Reported: 2018-02-07 13:44 UTC by Dominique Leuenberger
Modified: 2018-03-12 14:50 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-07 13:44:48 UTC
openSUSE Factory is in progress of merging GLIBC 2.27 - guile is amongst the packages failing to build

Build log is available at https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:C/guile/standard/x86_64
Comment 1 Dominique Leuenberger 2018-02-20 09:31:38 UTC
The devel prj moved to guile-2.2, which causes its own set of problems (none of the major players in the distro supports guile-2.2 yet)

IMHO we should unblock ourselves here and provide guile-2.0 fixed for glibc 2.27.
Comment 2 Dominique Leuenberger 2018-02-26 08:38:47 UTC
FYI: All other ring packages moved to glibc2.27 compatibility; guile is the only one failing as of now.
Comment 3 Andreas Schwab 2018-03-06 13:34:54 UTC
Fixed.