Bug 1079786 - wpa supplicant cant authenticate
wpa supplicant cant authenticate
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 10:08 UTC by Anatoly Litovsky
Modified: 2018-02-08 06:45 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
dmeg logs (107.18 KB, text/x-log)
2018-02-07 18:35 UTC, Anatoly Litovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anatoly Litovsky 2018-02-07 10:08:12 UTC
When upgrading to kernel 4.15.0-1 the wpa_supplicant fails to authenticate for several attempts, rolling back to 4.14.15-1 works like a charm

when using the wired network on 4.15.0-1 also had to force dhclient renew and set dns to 8.8.8.8 to force any networking at all

wpa_supplicant log 
wlp1s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="snowcat5"
wlp1s0: Trying to associate with 14:cc:20:d0:21:06 (SSID='snowcat5' freq=5220 MHz)
wlp1s0: Authentication with 14:cc:20:d0:21:06 timed out.
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=14:cc:20:d0:21:06 reason=3 locally_generated=1
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="snowcat5" auth_failures=2 duration=20 reason=CONN_FAILED
wlp1s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="snowcat5"
wlp1s0: Trying to associate with 14:cc:20:d0:21:06 (SSID='snowcat5' freq=5220 MHz)
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=14:cc:20:d0:21:06 reason=3 locally_generated=1
wlp1s0: Trying to associate with 14:cc:20:d0:21:05 (SSID='snowcat24' freq=2437 MHz)
wlp1s0: Authentication with 14:cc:20:d0:21:05 timed out.
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=14:cc:20:d0:21:05 reason=3 locally_generated=1
Comment 1 Jiri Slaby 2018-02-07 17:30:50 UTC
Could you attach also dmesg after it fails?
Comment 2 Anatoly Litovsky 2018-02-07 18:35:11 UTC
Created attachment 759313 [details]
dmeg logs
Comment 3 Anatoly Litovsky 2018-02-07 18:38:22 UTC
The problem doesn't reproduce if 4.15.1-2.g9df97e2-default is used from kernel: stable repo

Rolling back to 4.15.0-1 and the problem is back again.
I think rolling the 4.15.1.-2 into tumbleweed repositories will solve the issue.
Comment 4 Jiri Slaby 2018-02-08 06:45:10 UTC
Ok, closing then, as 4.15.1 was accepted to tumbleweed and waits for distributing a snapshot.