Bug 1079780 - [Build 20180206] openQA test fails in grub_test because missing line in grub menu about snapshot
[Build 20180206] openQA test fails in grub_test because missing line in grub ...
Status: RESOLVED DUPLICATE of bug 1078481
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
All Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
https://openqa.opensuse.org/tests/603...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 09:50 UTC by Michel Normand
Modified: 2018-02-22 12:43 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
aschnell: needinfo? (mchang)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-02-07 09:50:47 UTC
[Build 20180206] openQA test fails in grub_test because missing line in grub menu about snapshot
Compared to previous passed 20180205 the missing line is:
"Start bootloader from a read-only snapshot"

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-boot_to_snapshot@ppc64le fails in
[grub_test](https://openqa.opensuse.org/tests/603539/modules/grub_test/steps/14)


## Reproducible

Fails since (at least) Build [20180206](https://openqa.opensuse.org/tests/603286)


## Expected result

Last good: [20180205](https://openqa.opensuse.org/tests/602200) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?version=Tumbleweed&machine=ppc64le&flavor=DVD&arch=ppc64le&distri=opensuse&test=boot_to_snapshot)
Comment 1 Ancor Gonzalez Sosa 2018-02-07 16:08:55 UTC
According to the YaST logs it looks to me like snapper was properly configured.

Arvin, may this be introduced by the recent changes in how snapper initializes the btrfs snapshots?
Comment 2 Arvin Schnell 2018-02-07 20:13:52 UTC
Could be that the scripts to generate the boot entries check whether a subvolume
is only a subvolume or a snapshot.

But snapshot no. 2 should still be listed and its type has not changed.

I tested on SLE15 Beta 6 and I cannot find the option to boot a snapshot although
the grub scripts have generated the file /.snapshots/grub-snapshot.cfg with three
entries.

Michael?
Comment 3 Dominique Leuenberger 2018-02-07 21:10:25 UTC
Not specific to PPC, Tumbleweed/x86_64 showing the same issue:

https://openqa.opensuse.org/tests/604176#step/grub_test/14
Comment 4 Michael Chang 2018-02-08 09:42:36 UTC
This is now being processed in bsc#1078481. Thanks.

*** This bug has been marked as a duplicate of bug 1078481 ***
Comment 5 Michael Chang 2018-02-08 09:43:35 UTC
FYI. The SR to Factory:
https://build.opensuse.org/request/show/574126
Comment 6 Dominique Leuenberger 2018-02-08 09:56:44 UTC
(In reply to Michael Chang from comment #4)
> This is now being processed in bsc#1078481. Thanks.
> 
> *** This bug has been marked as a duplicate of bug 1078481 ***

Just a usual rant: dup'ing a public bug against a private one is 'sub-optimal'
Comment 7 Michel Normand 2018-02-08 09:58:44 UTC
(In reply to Dominique Leuenberger from comment #6)
> (In reply to Michael Chang from comment #4)
> > This is now being processed in bsc#1078481. Thanks.
> > 
> > *** This bug has been marked as a duplicate of bug 1078481 ***
> 
> Just a usual rant: dup'ing a public bug against a private one is
> 'sub-optimal'

yes :( I am not able to access it
Comment 8 Dominique Leuenberger 2018-02-11 19:30:14 UTC
(In reply to Michael Chang from comment #5)
> FYI. The SR to Factory:
> https://build.opensuse.org/request/show/574126

This is an SR to the devel project, not to Factory. Please submit the fix to openSUSE:Factory
Comment 9 Michel Normand 2018-02-16 07:46:45 UTC
correction validated with TW snapshot 20180213
https://openqa.opensuse.org/tests/609619#step/grub_test/1
Comment 10 Michael Chang 2018-02-21 07:36:20 UTC
*** Bug 1081425 has been marked as a duplicate of this bug. ***
Comment 11 Marc collin 2018-02-22 12:43:10 UTC
when that will be available?