Bug 1079748 - TW20180203 - SDDM white login screen
TW20180203 - SDDM white login screen
Status: RESOLVED DUPLICATE of bug 1079465
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 07:47 UTC by Jan T
Modified: 2018-02-08 04:51 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan T 2018-02-07 07:47:52 UTC
After the latest TW upgrade to 20180203 the SDDM login screen is complete white. There is only the mouse cursor.
Nevertheless I'm able to login by entering my password and hit "Enter".
If I downgrade Mesa to 17.3.3 the login screen is normal but then the
GPU hangs come back (see boo#1077998)

As I tested Mesa 18.0.0 RC3 before, the white login screen started for me with the upgrade to 20180130.

Please let me know if you need any log entries.
Comment 1 Michal Srb 2018-02-07 08:12:10 UTC
It could be the same issue as bug #1079465. Can you please test with Mesa packages from https://build.opensuse.org/project/show/home:michalsrb:branches:bnc1079465:X11:XOrg ?

Tumbleweed repository:
https://download.opensuse.org/repositories/home:/michalsrb:/branches:/bnc1079465:/X11:/XOrg/openSUSE_Tumbleweed/

After installing the packages, delete the ~/.cache directory of affected users. For sddm it is /var/lib/sddm/.cache.
Comment 2 Jan T 2018-02-07 08:35:51 UTC
Indeed. Using your Mesa packages fixed it. But - as you said - I had to remove the cache files in /var/lib/sddm/.cache. Otherwise the login screen remained white.

By the way: This also fixed boo#1079465 for me.
Comment 3 Michal Srb 2018-02-07 08:39:34 UTC
Thanks, closing the bug as duplicate.

*** This bug has been marked as a duplicate of bug 1079465 ***
Comment 4 Frank Krüger 2018-02-07 18:21:47 UTC
(In reply to Michal Srb from comment #1)
> It could be the same issue as bug #1079465. Can you please test with Mesa
> packages from
> https://build.opensuse.org/project/show/home:michalsrb:branches:bnc1079465:
> X11:XOrg ?
> 
> Tumbleweed repository:
> https://download.opensuse.org/repositories/home:/michalsrb:/branches:/
> bnc1079465:/X11:/XOrg/openSUSE_Tumbleweed/
> 
> After installing the packages, delete the ~/.cache directory of affected
> users. For sddm it is /var/lib/sddm/.cache.

My TW20180205 system was working pretty well until today's update of the above-mentioned Mesa packages via the Tumbleweed update repo: Now I have encountered a white sddm screen and a black desktop (removing user's and sddm's cache solved the issue). But was this to be expected?
Comment 5 Stefan Dirsch 2018-02-08 04:51:20 UTC
(In reply to Frank Kruger from comment #4)
> My TW20180205 system was working pretty well until today's update of the
> above-mentioned Mesa packages via the Tumbleweed update repo: Now I have
> encountered a white sddm screen and a black desktop (removing user's and
> sddm's cache solved the issue). But was this to be expected?

Yes.