Bug 1079553 - Thinkpad T460 Microphone mute key no longer works on KDE
Thinkpad T460 Microphone mute key no longer works on KDE
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-06 11:23 UTC by Maurizio Galli
Modified: 2018-02-22 04:54 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maurizio Galli 2018-02-06 11:23:37 UTC
Hello the Microphone Mute key no longer toggle microphone on and off on KDE 5.11.95. Global Shortcut is correctly assigned. The key also has a led indicating mute state.

However I can toggle the microphone between mute and unmute by using:

- System tray Audio Volume Settings (key led also toggles)
- "amixer set Capture toggle" in terminal (key led also toggles)


Any fix or workaround would be appreciated. It works fine on openSUSE Leap 42.3.
Comment 1 Maurizio Galli 2018-02-06 15:50:58 UTC
Tumbleweed Snapshot 20180203
Comment 2 Karl Cheng 2018-02-09 11:40:20 UTC
Hi, thanks for filing this bug report.

I'm guessing that this is caused by the same thing as bug 1078487, so I'll close this as a duplicate for now.

If it turns out to be unrelated, please let me know so I can reverse this change. Thank you!

*** This bug has been marked as a duplicate of bug 1078487 ***
Comment 3 Maurizio Galli 2018-02-09 12:28:42 UTC
Hi Kevin, thanks for commenting. 

I don't know if it's the same bug as in my case only the Microphone key doesn't mute. It only happens when using KDE. I tried latest snapshot of GNOME and the key works. 

xev output also indicates me that the key is working.

I think my issue is related to a new bug in KDE 5.12 as reported by these bugs too:

- https://bugs.kde.org/show_bug.cgi?id=390094
- https://bugs.kde.org/show_bug.cgi?id=389991 (maybe)


As a temporary workaround a bash script to run "amixer set Capture toggle" and kdedialog for basic notifications. I assigned it to the Microphone key in Global Shortcuts and it works. 

What do you think?
Comment 4 Maurizio Galli 2018-02-09 12:47:29 UTC

What do you think?(In reply to Maurizio Galli from comment #3)
> Hi Kevin, thanks for commenting. 
> 
> I don't know if it's the same bug as in my case only the Microphone key
> doesn't mute. It only happens when using KDE. I tried latest snapshot of
> GNOME and the key works. 
> 
> xev output also indicates me that the key is working.
> 
> I think my issue is related to a new bug in KDE 5.12 as reported by these
> bugs too:
> 
> - https://bugs.kde.org/show_bug.cgi?id=390094
> - https://bugs.kde.org/show_bug.cgi?id=389991 (maybe)
> 
> 
> As a temporary workaround a bash script to run "amixer set Capture toggle"
> and kdedialog for basic notifications. I assigned it to the Microphone key
> in Global Shortcuts and it works. 
> 
> What do you think?

Hi Karl, sorry for calling you Kevin in my other post! I was talking to a Kevin while typing and the name slipped in.
Comment 5 Karl Cheng 2018-02-14 12:02:47 UTC
It appears that this was indeed a separate issue, my apologies for prematurely marking this as a duplicate.

The following links says that this should be fixed in Plasma 5.12.1: https://bugs.kde.org/show_bug.cgi?id=390161
Comment 6 Maurizio Galli 2018-02-15 16:54:49 UTC
(In reply to Karl Cheng from comment #5)
> It appears that this was indeed a separate issue, my apologies for
> prematurely marking this as a duplicate.
> 
> The following links says that this should be fixed in Plasma 5.12.1:
> https://bugs.kde.org/show_bug.cgi?id=390161

Don't worry about it :). Thanks a lot for the update on this. I'm waiting for the update to hit Tumbleweed then.
Cheers
Comment 7 Maurizio Galli 2018-02-22 04:54:22 UTC
(In reply to Karl Cheng from comment #5)
> It appears that this was indeed a separate issue, my apologies for
> prematurely marking this as a duplicate.
> 
> The following links says that this should be fixed in Plasma 5.12.1:
> https://bugs.kde.org/show_bug.cgi?id=390161

I just updated Tumbleweed to Plasma 5.12.1 and I confirm that the bug has been squashed. Thanks a lot!