Bug 1079547 - amdgpu/Polaris11: Wrong low resolution after running xrandr or switching off/on monitor
amdgpu/Polaris11: Wrong low resolution after running xrandr or switching off/...
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 Other
: P3 - Medium : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-06 10:57 UTC by andrey yakunin
Modified: 2018-07-05 14:08 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
xorg right after changing resolution (83.92 KB, text/plain)
2018-02-06 10:57 UTC, andrey yakunin
Details
dmesg after broken resolution (89.83 KB, text/plain)
2018-02-06 11:00 UTC, andrey yakunin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrey yakunin 2018-02-06 10:57:32 UTC
Created attachment 758975 [details]
xorg right after changing resolution

Some issues with screen resolution. 

Resolution is ok after reboot (3840x2160) but when i switch monitor off/on resolution changes to 1368x768.
Same effect when i run xrandr in Konsole after reboot. Resolution changes to 
1368x768 immediately. 
After resolution changes to lower it is impossible to make it higher. 
amdgp, radeon rx 560
 uname -a
Linux localhost 4.15.0-1-default #1 SMP PREEMPT Wed Jan 31 07:03:28 UTC 2018 (ac01747) x86_64 x86_64 x86_64 GNU/Linux

xrandr after                                                       
Screen 0: minimum 320 x 200, current 1368 x 768, maximum 16384 x 16384                        
DisplayPort-0 connected primary 1368x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1368x768      59.88*                                                                       
   1280x800      59.81                                                                        
   1280x720      59.86                                                                                                              
   1024x768      60.00                                                                                                              
   1024x576      59.90                                                                                                              
   960x540       59.63                                                                                                              
   800x600       60.32                                                                                                              
   800x450       59.82                                                                                                              
   700x450       59.88                                                                                                              
   640x480       59.94                                                                                                              
   684x384       59.88    59.85                                                                                                     
   640x400       59.88    59.98  
   640x360       59.86    59.83  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32  
   320x240       60.05  
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
Comment 1 andrey yakunin 2018-02-06 11:00:42 UTC
Created attachment 758978 [details]
dmesg after broken resolution
Comment 2 Stefan Dirsch 2018-02-06 11:32:57 UTC
Hmm. Looks like a bug in amdgpu KMS driver. :-(
Comment 3 Stefan Dirsch 2018-03-27 01:55:20 UTC
Hmm. Is this still reproducable with the latest TW kernel?
Comment 4 andrey yakunin 2018-04-02 11:57:14 UTC
Unfortunately my  hardware(Radeon RX560) died, so it is impossible to reproduce the bug. I'm sorry.
Comment 5 Stefan Dirsch 2018-04-02 18:54:49 UTC
Ok. Then better close this issue.