Bug 1079543 - no cursor keys in midnight commander
no cursor keys in midnight commander
Status: RESOLVED FIXED
: 1079923 1080293 1080313 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal with 1 vote (vote)
: ---
Assigned To: Vladimir Nadvornik
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-06 10:26 UTC by Marvin FourtyTwo
Modified: 2018-02-19 23:40 UTC (History)
11 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
werner: needinfo?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marvin FourtyTwo 2018-02-06 10:26:13 UTC
I guess this is related to the last ncurses update. Using "TERM=xterm mc" makes them work again. Terminal is konsole. xterm has the same problem when TERM set to xterm-256color (default in konsole). Works fine in text console.
Comment 2 Dr. Werner Fink 2018-02-07 09:39:37 UTC
Args ... slang is broken. As long as slang does not use ncurses API to read the terminfo entries mc should be build with ncurses/tinfo
Comment 3 Wolfgang Bauer 2018-02-07 21:48:43 UTC
*** Bug 1079923 has been marked as a duplicate of this bug. ***
Comment 4 Dr. Werner Fink 2018-02-09 08:56:52 UTC
Just submitted SR#574532 with upstream commit which should add support for the new 32bit ncurses terminfo format ... please test out
Comment 5 Swamp Workflow Management 2018-02-09 09:30:15 UTC
This is an autogenerated message for OBS integration:
This bug (1079543) was mentioned in
https://build.opensuse.org/request/show/574532 Factory / slang
Comment 6 Vlastimil Babka 2018-02-09 10:12:33 UTC
(In reply to Dr. Werner Fink from comment #4)
> Just submitted SR#574532 with upstream commit which should add support for
> the new 32bit ncurses terminfo format ... please test out

Works for me, thanks!
Comment 7 Marvin FourtyTwo 2018-02-09 10:31:13 UTC
also fixes it for me.

Thanks!
Comment 8 Egmont Koblinger 2018-02-09 15:20:35 UTC
*** Bug 1080313 has been marked as a duplicate of this bug. ***
Comment 9 Aleksey Kontsevich 2018-02-09 16:07:25 UTC
When patched version will be available in Tumbleweed? How to fix now: not clear where to download rpm - URL?
Comment 10 Aleksey Kontsevich 2018-02-09 16:13:28 UTC
Nevermind, found, fixed.
Comment 11 Dr. Werner Fink 2018-02-09 17:18:29 UTC
For all others, see https://download.opensuse.org/repositories/devel:/libraries:/c_c++/openSUSE_Factory/
Comment 12 Dr. Werner Fink 2018-02-10 08:15:38 UTC
*** Bug 1080293 has been marked as a duplicate of this bug. ***
Comment 13 Dr. Werner Fink 2018-02-16 07:15:52 UTC
What is the status of this report? do now all slang based applications behave well with xterm-256color or other 32bit format terminfo entries?
Comment 14 Marvin FourtyTwo 2018-02-16 07:51:11 UTC
I think it's all well - new packages are in tumbleweed - closing.
Comment 16 Swamp Workflow Management 2018-02-19 23:40:24 UTC
This is an autogenerated message for OBS integration:
This bug (1079543) was mentioned in
https://build.opensuse.org/request/show/577162 15.0 / slang