Bug 1079304 - [Build 20180203] kdump failure: cannot resolve 'init_task_union'
[Build 20180203] kdump failure: cannot resolve 'init_task_union'
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: David Mair
E-mail List
https://openqa.opensuse.org/tests/601...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-05 08:47 UTC by Dominique Leuenberger
Modified: 2019-11-26 14:36 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-05 08:47:54 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
[kdump_and_crash](https://openqa.opensuse.org/tests/601421/modules/kdump_and_crash/steps/49)


## Reproducible

Fails since (at least) Build [20170428](https://openqa.opensuse.org/tests/395051)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?flavor=DVD&machine=64bit&version=Tumbleweed&distri=opensuse&test=extra_tests_in_textmode&arch=x86_64)

Issue started happening since the upgrade to kernel 4.15, the command used is

crash `ls -1t /var/crash/*/vmcore | head -n1` /boot/vmlinux-`uname -r`.gz

But apparently this no longer triggers 'the crash'
This error happens since the upgrade of the kernel to version 4.15.0
Comment 1 Jiri Slaby 2018-02-08 12:59:08 UTC
This is likely a crash issue. Maybe crash needs to be updated to support current kernel?
Comment 2 Julian Wolf 2018-03-20 10:14:32 UTC
Ran into this problem today running crash. It shows that crash 7.2.0 has a problem with the 4.15 kernel, crash 7.2.1 shouldn't have the problem anymore.

Fix:

https://github.com/crash-utility/crash/commit/494a796e112869cf5df482dc7618868eca7cf2d5

Release:

https://github.com/crash-utility/crash/releases/tag/7.2.1

I tried packaging 7.2.1 myself but ran into some build problems (with existing patches I guess?) I don't know how to solve properly.
Comment 3 David Mair 2018-03-20 15:03:39 UTC
(In reply to Jiri Slaby from comment #1)
> This is likely a crash issue. Maybe crash needs to be updated to support
> current kernel?

https://build.opensuse.org/request/show/588732

It was only submitted the day before this post mainly for the reasons being brought up in this bug. If is accepted I'll update this bug.
Comment 4 Dominique Leuenberger 2019-11-26 14:36:02 UTC
(In reply to David Mair from comment #3)
> (In reply to Jiri Slaby from comment #1)
> > This is likely a crash issue. Maybe crash needs to be updated to support
> > current kernel?
> 
> https://build.opensuse.org/request/show/588732
> 
> It was only submitted the day before this post mainly for the reasons being
> brought up in this bug. If is accepted I'll update this bug.

merged a long time ago