Bug 1079226 - go: introduce 1.8.x, 1.9.x and metapackage
go: introduce 1.8.x, 1.9.x and metapackage
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Maintenance
Leap 42.3
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Mr Maintenance
Mr Maintenance
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-03 20:21 UTC by Andreas Stieger
Modified: 2018-02-06 02:08 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2018-02-03 20:21:36 UTC
The SLE maintenance incident 6629 was just imported into the openSUSE Maintenance queue: https://build.opensuse.org/project/show/openSUSE:Maintenance:7760

It includes the following changes:

openSUSE:Leap:42.3:Update/go 1.9.2 "make go be a metapackage"
openSUSE:Leap:42.3:Update/go1.7 1.7.5 new package
openSUSE:Leap:42.3:Update/go1.8 1.8.5 new package
openSUSE:Leap:42.3:Update/go1.9 1.9.2 new package
openSUSE:Leap:42.3:Update/golang-packaging

So this retains 1.7.5, adds 1.8.5 and 1.9.2 and introduces the metapackage.
This will be copied from SLE and these package will follow SLE for maintenance going forward (although it is in the code stream only, not in a maintained product atm)

If anyone has any objections, please speak up.
Comment 1 Swamp Workflow Management 2018-02-03 22:00:06 UTC
This is an autogenerated message for OBS integration:
This bug (1079226) was mentioned in
https://build.opensuse.org/request/show/572343 Backports:SLE-12+Backports:SLE-12-SP1 / go+go1.7+go1.8+go1.9
Comment 2 Aleksa Sarai 2018-02-04 02:04:43 UTC
SGTM, this matches what we already do in Tumbleweed.
Comment 3 Andreas Stieger 2018-02-05 21:25:21 UTC
okay let's go with this.
Comment 4 Swamp Workflow Management 2018-02-06 02:07:20 UTC
openSUSE-OU-2018:0367-1: An update that has one optional fix can now be installed.

Category: optional (low)
Bug References: 1079226
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    go-1.9.2-30.1, go1.7-1.7.5-2.1, go1.8-1.8.5-2.1, go1.9-1.9.2-2.1, golang-packaging-15.0.7-14.1
Comment 5 Swamp Workflow Management 2018-02-06 02:08:14 UTC
openSUSE-OU-2018:0369-1: An update that has one optional fix can now be installed.

Category: optional (low)
Bug References: 1079226
CVE References: 
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    go-1.9.2-8.1, go1.7-1.7.5-2.1, go1.8-1.8.5-2.1, go1.9-1.9.2-2.1