Bug 1079101 - FTBFS: openSUSE:Factory/opensc fails to build
FTBFS: openSUSE:Factory/opensc fails to build
Status: RESOLVED DUPLICATE of bug 1074799
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stanislav Brabec
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-02 14:25 UTC by Dominique Leuenberger
Modified: 2018-02-05 19:58 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-02 14:25:41 UTC
The package opensc fails to build in openSUSE:Factory. Earlier notifications by email to the bugowner and Maintainer have remained without reaction / fix. If the package is not being fixed within 2 weeks, it will be scheduled for removal from Tumbleweed
Comment 1 Stanislav Brabec 2018-02-05 19:37:07 UTC
It is related to the new openssl:

[   16s] pkcs15-westcos.c:258:5: error: dereferencing pointer to incomplete type 'RSA {aka struct rsa_st}'
[   16s]   rsa->meth = RSA_PKCS1_SSLeay();
[   16s]      ^~

[   16s] pkcs15-westcos.c:258:14: warning: implicit declaration of function 'RSA_PKCS1_SSLeay'; did you mean 'RSA_PKCS1_OpenSSL'? [-Wimplicit-function-declaration]
Comment 2 Stanislav Brabec 2018-02-05 19:58:19 UTC
Actually, the fix was declined due to the short changelog entry:
https://build.opensuse.org/request/show/571357

New request:
https://build.opensuse.org/request/show/573128

*** This bug has been marked as a duplicate of bug 1074799 ***