Bug 1078844 - FTBFS: openSUSE:Factory/john fails to build
FTBFS: openSUSE:Factory/john fails to build
Status: RESOLVED FIXED
: 1074794 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Lars Vogdt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-01 17:08 UTC by Dominique Leuenberger
Modified: 2018-11-16 11:33 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-01 17:08:58 UTC
The package john fails to build in openSUSE:Factory. Earlier notifications by email to the bugowner and Maintainer have remained without reaction / fix. If the package is not being fixed within 2 weeks, it will be scheduled for removal from Tumbleweed
Comment 1 Thomas Zimmermann 2018-02-15 12:27:31 UTC
Here is the upstream issue: https://github.com/magnumripper/JohnTheRipper/issues/2355
Unfortunately upstream hasn't released any release since fixing this issue and the new code has diverged a lot from the last release so that back porting might not be easy.

One solution could be disabling all plugins that fail to build.
Comment 2 Dominique Leuenberger 2018-03-27 11:16:13 UTC
591568  State:new        By:dimstar      When:2018-03-27T11:15:48
        submit:          home:dimstar:Factory/john@3 ->                     security
        Descr: - Build against openSSL 1.0 until upstream catches up
               (boo#1078844).
Comment 3 Dominique Leuenberger 2018-05-08 12:08:26 UTC
(In reply to Dominique Leuenberger from comment #2)
> 591568  State:new        By:dimstar      When:2018-03-27T11:15:48
>         submit:          home:dimstar:Factory/john@3 ->                    
> security
>         Descr: - Build against openSSL 1.0 until upstream catches up
>                (boo#1078844).

was accepted
Comment 4 Vítězslav Čížek 2018-11-16 11:33:39 UTC
*** Bug 1074794 has been marked as a duplicate of this bug. ***