Bug 1078811 - Print kipi-plugins not working in gwenview
Print kipi-plugins not working in gwenview
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-01 15:58 UTC by Mark Petersen
Modified: 2018-02-02 10:51 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Petersen 2018-02-01 15:58:49 UTC
On my fully updated desktop and laptop Tumbleweed computers. In gwenview when I select Plugins > Images > both Print Images and Print assistant are greyed out. The File > Print function does work, but I cannot set the picture size. - It fills the page.

Current versions of packages installed:
gwenview5         17.12.1-1.1
kipi-plugins       5.8.0-3.1
libKF5Kipi32_0_0  17.12.1-1.1
libkipi-data      17.12.1-1.1

In Digikam: Tools > Print Creator... does bring up a "print assistant" dialog box, and I am able to select number of prints per page etc.

Mark
Comment 1 Wolfgang Bauer 2018-02-01 16:33:01 UTC
Works fine here. (I'm not using Tumbleweed though, but with the latest Factory packages on 42.3)

Does this only apply to the print plugins, or do the others not work either?

Could you please gwenview in a terminal window (e.g. Konsole), open the "Plugins" menu and post the output?
Comment 2 Wolfgang Bauer 2018-02-01 16:42:00 UTC
(In reply to Wolfgang Bauer from comment #1)
> Could you please gwenview in a terminal window (e.g. Konsole), open the
> "Plugins" menu and post the output?

Sorry, "please *run* gwenview in a terminal window"...
Comment 3 Paul Tannington 2018-02-01 17:03:17 UTC
Just to confirm, seeing the same behaviour of greyed out "Print Images" & "Print Assistant..." as the OP.

TW 20180130, same package versions.

One warning error:
kipi.library: Plugin  "KMLExport"  was not loaded because the host application is missing the feature  "ImagesHasTime"

All plugins load, including kipi.library: Loaded plugin  "PrintImages"

Other plugins appear to work OK.
Comment 4 Mark Petersen 2018-02-01 17:15:50 UTC
I'm seeing this when run from konsole:

user@n1250:~> gwenview
kipi.library: Plugin  "KMLExport"  was not loaded because the host application is missing
 the feature  "ImagesHasTime"
kipi.plugins: Plugin_SendImages plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_sendimagesui.rc"
kipi.library: Loaded plugin  "SendImages"
kipi.plugins: Plugin_YandexFotki plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_yandexfotkiui.rc"
kipi.library: Loaded plugin  "YandexFotki"
kipi.plugins: Plugin_Piwigo plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_piwigoui.rc"
kipi.library: Loaded plugin  "Piwigo"
kipi.plugins: Reading data from kipirc file..
kipi.plugins: Plugin_Dropbox Plugin Loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_dropboxui.rc"
kipi.library: Loaded plugin  "Dropbox"
kipi.plugins: Plugin_Imageshack plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_imageshackui.rc"
kipi.library: Loaded plugin  "Imageshack"
kipi.plugins: Plugin_Vkontakte plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_vkontakteui.rc"
kipi.library: Loaded plugin  "VKontakte"
kipi.plugins: Plugin_Flickr plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_flickrui.rc"
kipi.library: Loaded plugin  "Flickr"
kipi.plugins: Plugin_JAlbum plugin loaded
kipi.plugins: Reading jAlbum data from kipirc file..
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_jalbumui.rc"
kipi.library: Loaded plugin  "JAlbum"
kipi.plugins: Plugin_Rajce plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_rajceui.rc"
kipi.library: Loaded plugin  "Rajce"
kipi.plugins: Plugin_Smug plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_smugui.rc"
kipi.library: Loaded plugin  "Smug"
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_flashexportui.rc"
kipi.library: Loaded plugin  "FlashExport"
kipi.plugins: Imgur plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_imgurui.rc"
kipi.library: Loaded plugin  "Imgur"
kipi.plugins: Plugin_PrintImages plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_printimagesui.rc"
kipi.library: Loaded plugin  "PrintImages"
kipi.plugins: Plugin_RemoteStorage plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_remotestorageui.rc"
kipi.library: Loaded plugin  "RemoteStorage"
kipi.plugins: Plugin_Facebook plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_facebookui.rc"
kipi.library: Loaded plugin  "Facebook"
kipi.plugins: Plugin_GoogleServices Plugin Loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_googleservicesui.rc"
kipi.library: Loaded plugin  "Google Services"
kipi.plugins: Plugin_MediaWiki plugin loaded
kipi.library: UI file : "/usr/share/kxmlgui5/kipi/kipiplugin_wikimediaui.rc"
kipi.library: Loaded plugin  "MediaWiki export

Mark
Comment 5 Wolfgang Bauer 2018-02-01 17:26:22 UTC
Looks fine, the Print plugin is loaded without errors.

Did you actually select a picture before opening the menu/trying to choose the Print plugins?
Comment 6 Mark Petersen 2018-02-01 17:33:47 UTC
Yes, I had selected a .png file. I now tried it with a .jpg and the print options are available. If I select the same .png file after selecting a .jpg then the print options are available. Same behavior each time I restart gwenview.
Comment 7 Wolfgang Bauer 2018-02-01 17:56:07 UTC
(In reply to Mark Petersen from comment #6)
> Yes, I had selected a .png file. I now tried it with a .jpg and the print
> options are available. If I select the same .png file after selecting a .jpg
> then the print options are available. Same behavior each time I restart
> gwenview.

Interesting.
And I am able to reproduce this now.
Actually it happens with a .jpg file selected too (when it is selected before you open the menu the first time) or anything else. Changing the selection seems to fix the broken state.
Strange that I didn't see this previously, when I tried to reproduce... :-/

Sounds more like an upstream problem then though.

At least you have a workaround for now... ;-)
Comment 8 Mark Petersen 2018-02-01 17:59:27 UTC
Wolfgang,

Will you report this to KDE or should I?
Comment 9 Wolfgang Bauer 2018-02-01 18:18:00 UTC
(In reply to Mark Petersen from comment #8)
> Will you report this to KDE or should I?

Whatever you prefer.

I can do it myself, as I can reproduce the problem now...
Comment 10 Mark Petersen 2018-02-01 19:32:53 UTC
Wolfgang,

Please go ahead and file the bug with KDE. Thanks.

Mark
Comment 11 Wolfgang Bauer 2018-02-02 10:51:35 UTC
See https://bugs.kde.org/show_bug.cgi?id=389794

The problem seems to be obvious: apparently the menu entries are unconditionally created as disabled. They are correctly enabled/disabled as appropriate when you change the selection, but that has no effect before you open the menu the first time as the menu entries do not exist yet...