Bug 1078783 - No graphical boot after upgrade
No graphical boot after upgrade
Status: RESOLVED DUPLICATE of bug 1079465
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-01 14:07 UTC by Dennis Irrgang
Modified: 2018-02-11 17:50 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Irrgang 2018-02-01 14:07:47 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build Identifier: 

After upgrading my laptop today it fails to boot into the graphical login screen. Login is possible and successful, but only onto the CLI.

I have rolled back successfully three times since I thought it was related to some configuration changes I had made to the repositories, but during my third and last try I left everything unchanged and did a regular zypper dup which resulted in the same error.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to openSUSE-release-20180130-1.2
2. Reboot
Actual Results:  
CLI login screen

Expected Results:  
Start graphical SDDM and allow login
Comment 1 Jean Delvare 2018-02-08 09:02:23 UTC
Same problem here. I have switched to lightdm as a temporary workaround.
Comment 2 Fabian Vogt 2018-02-08 09:11:11 UTC
Very likely a dup of bug 1079465. Please update Mesa and delete all caches.
Comment 3 Jean Delvare 2018-02-11 08:57:18 UTC
I confirm that upgrading Mesa and deleting /var/lib/sddm/.cache fixed the graphical login with sddm.

*** This bug has been marked as a duplicate of bug 1079465 ***