Bug 1078716 - Kubic Installation -- Calling the YaST module inst_casp_overview has failed
Kubic Installation -- Calling the YaST module inst_casp_overview has failed
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/ql7QFh3P
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-01 08:59 UTC by Jason Evans
Modified: 2019-02-06 15:55 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2log (264.07 KB, text/plain)
2018-02-01 08:59 UTC, Jason Evans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Evans 2018-02-01 08:59:07 UTC
Created attachment 758373 [details]
y2log

Build: Snapshot20180130
VM: KVM
y2log attached.
Comment 1 Ancor Gonzalez Sosa 2018-02-01 10:04:42 UTC
The problem is that GuidedSetup.initial was unable to create a valid proposal (likely because /dev/vda is too small for Kubic requirements). But instead of reporting an "storage proposal not possible" error, it crashed when trying to assign the non-existing proposal here

https://github.com/yast/yast-storage-ng/blob/master/src/lib/y2storage/clients/partitions_proposal.rb#L163
Comment 2 Jason Evans 2018-02-01 10:39:40 UTC
(In reply to Ancor Gonzalez Sosa from comment #1)
> The problem is that GuidedSetup.initial was unable to create a valid
> proposal (likely because /dev/vda is too small for Kubic requirements). But
> instead of reporting an "storage proposal not possible" error, it crashed
> when trying to assign the non-existing proposal here
> 
> https://github.com/yast/yast-storage-ng/blob/master/src/lib/y2storage/
> clients/partitions_proposal.rb#L163

Cool, thanks for the info. I increased the qcow to 40G and it's working now.
Please close the bug.
Comment 3 Ancor Gonzalez Sosa 2018-02-01 11:19:55 UTC
(In reply to Jason Evans from comment #2)
> (In reply to Ancor Gonzalez Sosa from comment #1)
> > The problem is that GuidedSetup.initial was unable to create a valid
> > proposal (likely because /dev/vda is too small for Kubic requirements). But
> > instead of reporting an "storage proposal not possible" error, it crashed
> > when trying to assign the non-existing proposal here
> > 
> > https://github.com/yast/yast-storage-ng/blob/master/src/lib/y2storage/
> > clients/partitions_proposal.rb#L163
> 
> Cool, thanks for the info. I increased the qcow to 40G and it's working now.
> Please close the bug.

I would not. The bug is still valid since it should have presented an understandable error and disabled the "Install" button. Instead, it showed a (kind of cryptic) error pop-up. I had to look into the logs to know what the problem was.
Comment 4 Ancor Gonzalez Sosa 2018-02-01 11:30:04 UTC
Added to the yast-team trello board for it to be prioritized in relation to other bugs.
Comment 5 Ancor Gonzalez Sosa 2019-02-06 15:55:43 UTC
I checked this and I'm 99.9% sure it was fixed a long time ago and the bug report was just overlooked and not closed. Feel free to reopen otherwise.