Bug 1078559 - unable to install rpm-build -> depends on rpm -> depends on python2-rpm-4.14.0-2.1.x86_64 -> cause wide spread deinstallation
unable to install rpm-build -> depends on rpm -> depends on python2-rpm-4.14....
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Schröder
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-31 16:56 UTC by a b
Modified: 2018-02-01 11:44 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a b 2018-01-31 16:56:18 UTC
Installing rpm-build causes a bunch of problems in tumbleweed.
It asks for rpm 14.4 that needs a python2-rpm-4.14.0-2.1.x86_64
and causes cause wide spread deinstallation X11, etc.

rpm -i rpm-build-4.14.0-511.14.x86_64.rpm
warning: rpm-build-4.14.0-511.14.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID e2c0098c: NOKEY
error: Failed dependencies:
        librpm.so.8()(64bit) is needed by rpm-build-4.14.0-511.14.x86_64
        librpmbuild.so.8()(64bit) is needed by rpm-build-4.14.0-511.14.x86_64
        librpmio.so.8()(64bit) is needed by rpm-build-4.14.0-511.14.x86_64
        rpm = 4.14.0 is needed by rpm-build-4.14.0-511.14.x86_64

the latest version of rpm is stalled but:
rpm -q rpm
rpm-4.13.0.1-9.1.x86_64


zypper update rpm
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Problem: rpm-python-4.13.0.1-9.1.x86_64 benötigt librpm.so.7()(64bit), kann jedoch nicht zur Verfügung gestellt werden
  Gelöschte Anbieter: rpm-4.13.0.1-9.1.x86_64
 Lösung 1: Ersatz von rpm-python-4.13.0.1-9.1.x86_64 durch python2-rpm-4.14.0-2.1.x86_64
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 Lösung 2: rpm-4.14.0-2.1.x86_64 nicht installieren
 Lösung 3: rpm-python-4.13.0.1-9.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen


Problem: libzypp-16.17.3-1.2.x86_64 benötigt librpm.so.7()(64bit), kann jedoch nicht zur Verfügung gestellt werden
  Gelöschte Anbieter: rpm-4.13.0.1-9.1.x86_64
 Lösung 1: Folgende Aktionen werden ausgeführt:
  Deinstallation von kwin5-5.11.2-1.1.x86_64
  Deinstallation von plasma5-session-5.11.2-1.2.noarch
  Deinstallation von plasma5-workspace-5.11.2-1.2.x86_64
  Ersatz von plasma5-workspace-lang-5.11.2-1.2.noarch durch bundle-lang-kde-ar-13.2-65.2.noarch
  Deinstallation von plasma5-desktop-5.11.2-1.2.x86_64
  Deinstallation von patterns-kde-kde_plasma-20170319-12.1.noarch
  Ersatz von plasma5-desktop-lang-5.11.2-1.2.noarch durch bundle-lang-kde-ar-13.2-65.2.noarch
  Deinstallation von patterns-kde-kde_imaging-20170319-12.1.noarch
  Deinstallation von patterns-kde-kde-20170319-12.1.noarch
  Deinstallation von sddm-branding-openSUSE-0.17.0-1.1.x86_64
 Lösung 2: Folgende Aktionen werden ausgeführt:
  Deinstallation von Mesa-17.2.3-177.1.x86_64
  Deinstallation von Mesa-libGL1-17.2.3-177.1.x86_64
  Deinstallation von xorg-x11-server-1.19.6-2.1.x86_64
  Deinstallation von xf86-input-evdev-2.10.5-2.1.x86_64
  Deinstallation von xf86-input-joystick-1.6.3-1.3.x86_64
  Deinstallation von xf86-input-keyboard-1.9.0-1.3.x86_64
  Deinstallation von xf86-input-libinput-0.26.0-1.1.x86_64
  Deinstallation von xf86-input-mouse-1.9.2-2.1.x86_64
  Deinstallation von xf86-input-synaptics-1.9.0-2.1.x86_64
  Deinstallation von xf86-input-void-1.4.1-3.1.x86_64
  Deinstallation von xf86-input-wacom-0.34.2-4.1.x86_64
  Deinstallation von xf86-video-fbdev-0.4.4-4.1.x86_64
  Deinstallation von xf86-video-vesa-2.3.4-4.1.x86_64
  Deinstallation von xorg-x11-driver-video-7.6_1-17.1.x86_64
 Lösung 3: Ersatz von libtxc_dxtn-1.0.1-1.1.x86_64 durch Mesa-17.3.3-183.1.x86_64
 Lösung 4: Deinstallation von libyui-qt-pkg8-2.45.14-1.1.x86_64
 Lösung 5: rpm-4.14.0-2.1.x86_64 nicht installieren
 Lösung 6: libzypp-16.17.3-1.2.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
Comment 1 Michael Schröder 2018-02-01 10:53:26 UTC
rpm-python was renamed to python2-rpm, i.e. "Lösung 1" is the one to choose. My guess is that you're running into libzypp bug #1071466, which makes libzypp ask for confirmation of package renames.

Anyway, not a problem in rpm.
Comment 2 a b 2018-02-01 11:44:14 UTC
no idea, the installtion was fresh (yesterday) all update installed.
I guess other ppl will have the sameproblem.

NTL i have replaced the TW with 42.2 because i had trouble at other places also