Bug 1078408 - X Segmentation fault at address 0x20
X Segmentation fault at address 0x20
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
64bit openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-31 05:27 UTC by Richard Pace
Modified: 2018-06-16 12:30 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (rpace)


Attachments
Xorg.0.log during boot (8.25 KB, text/plain)
2018-05-11 16:21 UTC, Richard Pace
Details
Xorg.0.log Kernel 4.14.12-1 (good boot) (42.97 KB, text/x-log)
2018-05-11 16:37 UTC, Richard Pace
Details
Kernel 4.16.6-1-default boot with nosplash (8.16 KB, application/x-trash)
2018-05-12 22:40 UTC, Richard Pace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Pace 2018-01-31 05:27:52 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build Identifier: 

Starting with kernel 4.14.13.1 system would not finish booting...the screen display the login prompt (right before it would normally go to the full screen user login page), and continusouly blink...after pressing enter key, this message is displayed and the screen continues to blink:
logitech-hidpp-device 0003:046D:200D.0006 Unable to retrieve the name of the device.

It seems that the system is not reading the device name correctly because 200D is not a valid logitech device.  Here is the lusb output when I boot back with 4.14.12.1:
richard@linux-nab9:~> lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0bda:0184 Realtek Semiconductor Corp. RTS5182 Card Reader
Bus 003 Device 007: ID 046d:082c Logitech, Inc. HD Webcam C615
Bus 003 Device 005: ID 0a5c:216c Broadcom Corp. BCM43142A0 Bluetooth Device
Bus 003 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 004: ID 0557:2255 ATEN International Co., Ltd 
Bus 003 Device 002: ID 0557:7000 ATEN International Co., Ltd Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

What more information do you need?

Reproducible: Always

Steps to Reproduce:
1. I presume it's the kernel level...4.14.12.1 works OK...Anytime I install updates that include a kernel update, it breaks.  So 4.14.13.1, 4.14.14.1 and 4.14.15.1 I have tried and they all fail with the same error conditions.  I recover by rolling back to 4.14.12.1

Actual Results:  
boot does not complete. at tty login, screen just blinks continuously and outputs the logitech error whenever enter key pressed.

Expected Results:  
boot to complete.
Comment 1 Richard Pace 2018-02-03 00:16:14 UTC
Kernel 4.14.15.1 did not resolve the problem.
Comment 2 Jiri Slaby 2018-02-13 11:36:37 UTC
I can't see anything obviously broken between 4.14.12 and 4.14.13 in this area.

Could you boot without splash-silent and quiet?
Comment 3 Richard Pace 2018-05-11 16:21:00 UTC
Created attachment 769933 [details]
Xorg.0.log during boot

Shows segment fault in X near end of log.
Comment 4 Richard Pace 2018-05-11 16:28:17 UTC
From just looking at the journald log I mistakenly viewed this as a usbhid problem.  But now looking at the Xorg.0.log I can see a segment fault.  Xorg.0.log attached from attempt to boot with the latest kernel 4.16.6-1-default.

Same symptoms as when first reported with 4.14.13-1 kernel. 

Reverting back to 4.14.12-1 i see that the X server is version 1.19.5, and the X server version that now fails with the segmentation fault is 1.19.6.  Not sure when 1.19.6 was introduced, but I suspect 4.14.13-1 was using 1.19.6.
Comment 5 Richard Pace 2018-05-11 16:37:13 UTC
Created attachment 769936 [details]
Xorg.0.log Kernel 4.14.12-1 (good boot)

Attached the Xorg.0.log for boot with kernel 4.14.12-1, when things work OK>
Comment 6 Richard Pace 2018-05-11 16:40:43 UTC
Also, I'll try to boot without Splash and quiet and report back.
Comment 7 Richard Pace 2018-05-12 22:40:59 UTC
Created attachment 769986 [details]
Kernel 4.16.6-1-default boot with nosplash

Attached log from boot with nosplash, with same result:
322.729] Current Operating System: Linux linux-nab9 4.16.6-1-default #1 SMP PREEMPT Mon Apr 30 20:33:51 UTC 2018 (566acbc) x86_64
[   322.729] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.16.6-1-default root=UUID=44d379df-676b-4295-b7aa-3e0503178afc rootflags=subvol=/@/.snapshots/593/snapshot

322.781] (EE) Segmentation fault at address 0x20
Comment 8 Richard Pace 2018-05-26 23:00:23 UTC
(In reply to Jiri Slaby from comment #2)
> I can't see anything obviously broken between 4.14.12 and 4.14.13 in this
> area.
> 
> Could you boot without splash-silent and quiet?

Any chance you could look at this again with the additional documentation?
Richard
Comment 9 Takashi Iwai 2018-05-27 05:54:50 UTC
Does your system have Mesa-dri package installed?
Comment 10 Jiri Slaby 2018-06-16 12:30:26 UTC
Closing due to lack of response.