Bug 1078284 - zypper crashes installing intel parallel studio rpms
zypper crashes installing intel parallel studio rpms
Status: RESOLVED FIXED
: 1079875 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-30 11:45 UTC by Fabian Wein
Modified: 2018-02-09 12:36 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
part of zypper.log for installing intel stuff (1.62 MB, text/x-log)
2018-01-30 14:10 UTC, Fabian Wein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Wein 2018-01-30 11:45:23 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build Identifier: 

With recent tumbleweed I cannot install intel parallel studios rpms any more. This holds for current parallel_studio_xe_2018_update1_cluster_edition, which can be installed on Leap 42.3, but also for the previous parallel_studio_xe_2018_cluster_edition which was installed on my tumbleweed before.

I tried installing via rpmdir and zypper in but also with intels install.sh. It also failed using my old rmpdir from which I installed without any problems about 6 month ago.

I conclude that my rpm's are not broken.


Reproducible: Always

Steps to Reproduce:
1. I tested with the commercial parallel_studio_xe_2018_update1_cluster_edition
2. sudo zypper addrepo /opt/intel_rpm_repository/parallel_studio_xe_2018_update1_cluster_edition  intel_parallel_studio_xe_2018_update1
3. sudo zypper in intel-mkl-core*

....
(18/18),  11.3 MiB ( 53.0 MiB unpacked)
intel-mkl-core-ps-2018.1-163-2018.1-163.x86_64.rpm:
/var/cache/zypp/packages/intel_parallel_studio_xe_2018_update1/rpm/intel-mkl-core-ps-2018.1-163-2018.1-163.x86_64.rpm: signature region 62: tag number mismatch il 7 ril 5 dl 658 rdl 16

intel-mkl-core-ps-2018.1-163-2018.1-163.x86_64 (intel_parallel_studio_xe_2018_update1): Signature verification failed [5-File does not exist or signature can't be checked]
Abort, retry, ignore? [a/r/i] (a): i
Checking for file conflicts: ...............................................................................................................................................[done]
zypper: /usr/include/boost/smart_ptr/intrusive_ptr.hpp:199: T* boost::intrusive_ptr<T>::operator->() const [with T = const zypp::target::rpm::RpmHeader]: Assertion `px != 0' failed.
Aborted


Actual Results:  
zypper aborts

Expected Results:  
rpms are installed

The new repodir is of category Plaindir, the old one is of category YUM. But I don't think this is an issue at also the old repo and Intel's install.sh fails.

Currently there is no official way to install Intel's MKL, compilers and vTunes on my system.
Comment 1 Josef Reidinger 2018-01-30 12:05:41 UTC
reassigning to zypp maintainer
Comment 2 Michael Andres 2018-01-30 13:46:59 UTC
AFAIK TW has changed to rpm-4.14. Most probably this causes the issue.

@Fabian:
- Could you please attach one of the failing rpms (to check the ignature region 62: tag number mismatch... error from rpm)?
- And the /var/log/zypper.log to check the crash in zypper.
Comment 3 Fabian Wein 2018-01-30 14:10:52 UTC
Created attachment 758069 [details]
part of zypper.log for installing intel stuff

part corresponding to 

sudo zypper in intel-mkl-core*
Comment 4 Michael Andres 2018-01-31 13:12:52 UTC
@Fabian: The package you sent has a 'broken' (at least non standard) signature. rpm-4.14 became more strict when checking the signature . That's why the package is not installable anymore.

Meanwhile upstream rpm already relaxed the checks (you're probably not the only one having this problem). The next rpm update should resolve this issue and again accept the package.
Comment 5 Michael Schröder 2018-01-31 14:14:10 UTC
See also https://bugzilla.redhat.com/show_bug.cgi?id=1514190
Comment 6 Michael Schröder 2018-01-31 14:15:28 UTC
(nevertheless zypper shouldn't throw an assertion when checking for file conflicts...)
Comment 7 Michael Andres 2018-01-31 15:29:31 UTC
(that's why the bug is still open)
Comment 8 Fabian Wein 2018-02-01 07:13:48 UTC
Thanks a lot! So I'll wait for rpm-4.14.1 or later to arrive at TW.
Comment 9 Michael Andres 2018-02-02 15:09:29 UTC
Crash fixed in libzypp-17.1.2
Comment 11 Michael Schröder 2018-02-08 16:18:41 UTC
*** Bug 1079875 has been marked as a duplicate of this bug. ***