Bug 1078266 - 96BoardsGPIO error on login
96BoardsGPIO error on login
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
aarch64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Pluskal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-30 10:40 UTC by Andreas Färber
Modified: 2018-03-08 13:24 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Färber 2018-01-30 10:40:38 UTC
After installing 96BoardsGPIO-devel and rebooting, logging in to the system via ssh gives me:

Have a lot of fun...
ERROR: Unable to find libsoc_gpio.conf
cat: /usr/local/etc/libsoc_gpio.conf: Datei oder Verzeichnis nicht gefunden
declare -x COLORTERM="1"
declare -x CPU="aarch64"
[...]
declare -x XNLSPATH="/usr/X11R6/lib/X11/nls"
hikey:~ # 

Expected would be the prompt right after "Have a lot of fun...".

a) Should that path be /etc/libsoc_gpio.conf? Doesn't exist either.
b) Should it really dig itself into my system that way?
Comment 1 Martin Pluskal 2018-01-30 11:51:24 UTC
(In reply to Andreas Färber from comment #0)
> After installing 96BoardsGPIO-devel and rebooting, logging in to the system
> via ssh gives me:
> 
> Have a lot of fun...
> ERROR: Unable to find libsoc_gpio.conf
> cat: /usr/local/etc/libsoc_gpio.conf: Datei oder Verzeichnis nicht gefunden
> declare -x COLORTERM="1"
> declare -x CPU="aarch64"
> [...]
> declare -x XNLSPATH="/usr/X11R6/lib/X11/nls"
> hikey:~ # 
> 
> Expected would be the prompt right after "Have a lot of fun...".
> 
> a) Should that path be /etc/libsoc_gpio.conf? Doesn't exist either.
Hmm it should be created
> b) Should it really dig itself into my system that way?
Yes
Comment 2 Martin Pluskal 2018-03-08 13:24:00 UTC
Missing configuration file is now provided.