Bug 1078206 - Upgrading to 20180128 breaks sudo and fails at switch root during boot
Upgrading to 20180128 breaks sudo and fails at switch root during boot
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: systemd maintainers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-30 05:49 UTC by Joshua Blair
Modified: 2018-06-22 10:55 UTC (History)
2 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
fbui: needinfo? (josh)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Blair 2018-01-30 05:49:07 UTC
Steps to recreate:

1. Perform a zypper dup - nothing out of the ordinary.
2. Wait a few minutes, attempt to use sudo for something, password will fail.
3. Try opening YaST and it'll complain user 'root' not found.
Reboot.
4. Startup will commence but fail at switch root (as far as I can tell).


To recover:


1. Boot into Maintenance Mode.
2. snapper list (get the numbers)
3. snapper -v undochange xx..xx
4. Reboot. The default option will no longer work, must go to advanced and select the previous kernel.


System Information:
Memory: 8GB
Processor: Intel Core i7-3687U
Graphics: Intel Ivybridge Mobile
Comment 1 Joshua Blair 2018-02-01 17:24:02 UTC
I held back the following packages and the upgrade was able to proceed.

    udev
    systemd
    systemd-bash-completion
    systemd-logger
    systemd-sysvinit
Comment 2 Tomáš Chvátal 2018-06-20 11:39:44 UTC
@systemd as it is 6 months old ticket it was quite probably solved in the meantime.
Comment 3 Franck Bui 2018-06-20 14:31:01 UTC
Well 6 months later Joshua probably lost interest in this...

Joshua, do you still have interest in fixing your issue ? if so can you still provide some debug logs ?
Comment 4 Franck Bui 2018-06-22 10:55:43 UTC
Perhaps a duplicate bug #1096050...

Anyway, I'm going to close this bug as Joshua probably solved his issue somehow now. Feel free to re-open if it's not the case and again sorry for the delay.