Bug 1078008 - [Build 20180128] yast2-tftp-server: undefined method 'name' for nil:NilClass
[Build 20180128] yast2-tftp-server: undefined method 'name' for nil:NilClass
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Knut Alejandro Anderssen González
Jiri Srain
https://openqa.opensuse.org/tests/595...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-29 15:32 UTC by Dominique Leuenberger
Modified: 2018-02-05 12:46 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-29 15:32:21 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
[yast2_tftp](https://openqa.opensuse.org/tests/595124/modules/yast2_tftp/steps/6)


## Reproducible

Fails since (at least) Build [20171029](https://openqa.opensuse.org/tests/518687)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?flavor=DVD&machine=64bit&version=Tumbleweed&test=yast2_ncurses&distri=opensuse&arch=x86_64)

One more module showing this error
Comment 1 Josef Reidinger 2018-01-29 17:24:05 UTC
knut is tftp already ported to firewalld or is it WIP?
Comment 2 Knut Alejandro Anderssen González 2018-01-29 19:54:03 UTC
No, it isn't. PR waiting for review:

https://github.com/yast/yast-ftp-server/pull/26
Comment 3 Knut Alejandro Anderssen González 2018-02-05 12:46:29 UTC
The bug was about tftp and I commented a PR for ftp.

The fix for yast2-tftp will be in version 4.0.0

https://github.com/yast/yast-tftp-server/pull/13 and jreidinger was the author (thnx!)