Bug 1077978 - p7zip contains non-free unrar code
p7zip contains non-free unrar code
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Kristyna Streitova
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-29 12:14 UTC by Kristyna Streitova
Modified: 2021-06-07 09:55 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristyna Streitova 2018-01-29 12:14:56 UTC
According to DOCS/License.txt, "CPP/7zip/Compress/Rar* files" have GNU LGPL + unRAR restriction licence. We should remove these RAR files from the p7zip package for both openSUSE Tumbleweed and SLE12/openSUSE Leap.
Comment 1 Kristyna Streitova 2018-01-29 13:20:48 UTC
|     Codestream      |  Request  |
|---------------------|-----------|
| openSUSE:Tumbleweed | #570599   |
| SUSE:SLE-12:Update  | #153196   |
| openSUSE:Leap       | via SLE12 |

Closing as fixed.
Comment 3 Swamp Workflow Management 2018-02-16 17:09:14 UTC
SUSE-SU-2018:0464-1: An update that solves three vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1077724,1077725,1077978,984650
CVE References: CVE-2016-1372,CVE-2017-17969,CVE-2018-5996
Sources used:
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    p7zip-9.20.1-7.3.1
SUSE Linux Enterprise Server 12-SP3 (src):    p7zip-9.20.1-7.3.1
SUSE Linux Enterprise Server 12-SP2 (src):    p7zip-9.20.1-7.3.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    p7zip-9.20.1-7.3.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    p7zip-9.20.1-7.3.1
Comment 4 Swamp Workflow Management 2018-02-20 17:17:09 UTC
openSUSE-SU-2018:0497-1: An update that solves three vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1077724,1077725,1077978,984650
CVE References: CVE-2016-1372,CVE-2017-17969,CVE-2018-5996
Sources used:
openSUSE Leap 42.3 (src):    p7zip-9.20.1-18.3.1
Comment 5 Swamp Workflow Management 2018-04-24 10:00:05 UTC
This is an autogenerated message for OBS integration:
This bug (1077978) was mentioned in
https://build.opensuse.org/request/show/600355 Factory / bash-completion