Bug 1077882 - [Build 20180127] openQA test fails in clone
[Build 20180127] openQA test fails in clone
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AutoYaST
Current
Other Other
: P2 - High : Normal (vote)
: ---
Assigned To: Ladislav Slezák
E-mail List
https://openqa.opensuse.org/tests/594...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-28 19:29 UTC by Dominique Leuenberger
Modified: 2022-07-12 08:33 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-28 19:29:09 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-autoyast_gnome@64bit fails in
[clone](https://openqa.opensuse.org/tests/594416/modules/clone/steps/3)


## Reproducible

Fails since (at least) Build [20180127](https://openqa.opensuse.org/tests/594154)


## Expected result

Last good: [20180126](https://openqa.opensuse.org/tests/593613) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?machine=64bit&flavor=NET&version=Tumbleweed&test=autoyast_gnome&distri=opensuse&arch=x86_64)


Test fails with a 'cannot allocate memory' error; the VM has been started with 1.5GB of RAM
Comment 1 Josef Reidinger 2018-01-29 12:22:48 UTC
lslezak - is possible that this call can also eat a lot of memory? https://github.com/yast/yast-autoinstallation/blob/master/src/modules/AutoinstSoftware.rb#L973

it also query properties, but only for single package.
Comment 2 Ladislav Slezák 2018-01-29 12:41:59 UTC
Hm, that should be OK, at least from the YaST POV. The code (https://github.com/yast/yast-pkg-bindings/blob/ed7b6c815964c5ea9ef11b6da80d45cb1a4b2302/src/Package.cc#L978-L1003) only checks the packages one-by-one, the memory should be deallocated after each call.

But the memory cloud be already eaten somewhere else earlier.

I have a fixed this issue https://github.com/yast/yast-country/pull/162, there are some more, I'll continue with removing that calls.

Let's see if that helps...
Comment 4 Ladislav Slezák 2018-01-30 09:52:08 UTC
I have replaced that problematic Pkg call in autoyast2-4.0.26 (https://github.com/yast/yast-autoinstallation/pull/393)

And also in yast2-country-4.0.18 (https://github.com/yast/yast-country/pull/162)

Please check whether these fixes help. If not then please reopen.
Comment 5 Ladislav Slezák 2018-01-31 13:53:57 UTC
JFYI: there is an additional optimization (speed up) in autoyast2-4.0.27 (https://github.com/yast/yast-autoinstallation/pull/394), the original fix was slow if the system had installed too many packages, it could took up to 20 minutes. Now the package cloning takes just few seconds as before.