Bug 1077868 - Installer Expert Partitioner has several issues with existing partition use
Installer Expert Partitioner has several issues with existing partition use
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
x86-64 Other
: P2 - High : Major (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/r6sk4mQB
https://trello.com/c/14Kfo6mY/202-5-e...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-28 11:15 UTC by Stuart Rogers
Modified: 2019-04-15 12:14 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Rogers 2018-01-28 11:15:57 UTC
I am trying to re-install Tumbleweed using my existing partitions and the openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180125-Media.iso which checksums fine. The Installer starts and gets to the partition setup. I select the Expert Partitioner using the existing partitions option which displays OK. Now I want to edit the partitions to ensure all system partitions are formatted. I start with the /boot/efi but if I tick Format the mount option is removed, also the Option button give an error, so my only option is to leave it without formatting and leave the mount as is, I then edit the root and home partitions to ensure formatting and click to finish at which point the partitioner complains the /boot/efi has no device and suggests the system may not boot. At which point I abort.

Using openSUSE-Tumbleweed-DVD-x86_64-Snapshot20170928-Media.iso the partitioner works fine with my existing partitions and allows me to edit them as I wish, also the Option button works fine, and finish without error. Note that to select the Expert Partitioner on this older iso there is no option to select the existing partitions it just opens with them anyway. I have still not done the install because using this snapshot iso will entail 4+ months of updates to be done.
Comment 1 Stuart Rogers 2018-01-28 15:28:28 UTC
Just double checked on how it fails and noticed that there is no VFAT option when trying to format /boot/efi partition. The Options button reports Not Implemented Yet.

Some of this makes me think that the installer added to this snapshot is in fact not a stable version but some work in progress, especially as the Options button works in the older snapshot.
Comment 4 Neil Rickert 2018-01-30 01:17:27 UTC
I download openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180128-Media.iso to test this.  I tested in a KVM virtual machine.

Test 1: I went to expert partitioner, with existing partitions.

I set the EFI partition to mount at "/boot/efi"
I set the root partition to be formatted and mounted at "/"
I set the home partition to be mounted at "/home"
I set the swap partition to be mounted at "swap" (I had to type in "swap" (without the quotes).

That all worked, though I aborted the install before it actually wrote to disk.

Test 2: Again, using expert partitioner with existing partitions.

I set the EFI partition to be formatted with FAT.  And it lost its property of being the EFI System Partition.  Although I set it to mount at "/boot/efi", and completed the steps for other partitions, I got that complaint about no "/boot/efi".

Test 3:  I then hit the "Back" button, and restarted the partitioning section.  I was then able to proceed as in Test1.

What I did not try, but might work:  I did not try deleting the EFI partition, and then adding it back.  That might work, because adding a partition gives more options than formatting.
Comment 5 Stuart Rogers 2018-01-30 07:53:09 UTC
One further point I have discovered after successful install on a new empty HDD is that the fstab built by the installer references the system disks by name eg. /dev/sda1 etc rather than by UUID which is a backwards step as the name can change if the disks are plugged in in a different order. From memory the Options (if it worked) would allow the disk to be referenced by UUID which in my view should be the default. There seem to be more bugs appearing in this installer each time I look at it.
Comment 6 Neil Rickert 2018-01-30 18:56:18 UTC
>references the system disks by name eg. /dev/sda1 etc rather than by UUID

This seems to be true for my install.

You can change that in the partitioner.  For each partition, click on "FSTAB options, and you can choose.  However the default seems to be device name.  And I agree with you, that UUID would be a better default.

However, I think you should report this as a new (different) bug.
Comment 7 Stuart Rogers 2018-01-30 19:56:42 UTC
From memory I think you need to click on Options button to change that but the issue with this installer is that the Option button does not work!
Comment 8 Steffen Winterfeldt 2018-02-13 14:39:54 UTC
The 'options' button has been added back with this pr:

https://github.com/yast/yast-storage-ng/pull/506

The other issue(s) described here is that you can only set the partition type if you do *not* format it - which is a bit strange. And the dialog 'forgets' the current partition type if you switch to 'format'.

I've created a new card in our scrum board for these issues. But please do *not* heap any further bugs you encounter in the expert partitioner onto this bugzilla entry. Remember the rule: one bug - one bug report.
Comment 9 José Iván López González 2018-03-12 14:37:49 UTC
With version 4.0.130 of yast2-storage-ng it will possible to manually edit the partition id.