Bug 1077851 - Missing German Translation in KDE Plasma5 Software Updates Applet for PackageKit
Missing German Translation in KDE Plasma5 Software Updates Applet for PackageKit
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-27 15:44 UTC by Frank Krüger
Modified: 2018-05-23 22:53 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Message with mixed languages (33.39 KB, image/png)
2018-01-28 14:31 UTC, Frank Krüger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krüger 2018-01-27 15:44:19 UTC
After upgrading to KDE 5.11.95 within a German environment, the plasma applet for software updates has no German translation for "Checking for updates failed". All the recommended *-lang packages are installed (TW 20180125).
Comment 1 Wolfgang Bauer 2018-01-28 12:07:36 UTC
I updated the translations to the latest svn revisions, this should fix it:
https://build.opensuse.org/request/show/570318

Btw, that's completely unrelated to Plasma 5.11.95... ;-)
Comment 2 Frank Krüger 2018-01-28 14:21:51 UTC
Updating to plasma5-pk-updates-0.3.1-35.1.x86_64 and plasma5-pk-updates-lang-0.3.1-35.1.noarch from https://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/ does not solve the above-mentioned issue (after logout/login).
Comment 3 Frank Krüger 2018-01-28 14:31:47 UTC
Created attachment 757821 [details]
Message with mixed languages

Message with mixed languages attached.
Comment 4 Wolfgang Bauer 2018-01-28 14:32:36 UTC
The translation is in the updated lang tarball though:

#: pkupdates.cpp:138
#, kde-format
msgid "Checking for updates failed"
msgstr "Die Suche nach Aktualisierungen ist fehlgeschlagen"

Hm.
Comment 5 Wolfgang Bauer 2018-01-28 14:44:43 UTC
And I just checked on my 42.3 system (with KDE:Frameworks5), that message *is* translated to german now.

You probably still use the old translations from bundle-lang-kde-de, which of course hasn't been updated yet (because the update is not in Tumbleweed yet).

Uninstall that and the applet should pick up the new/latest translations from plasma5-pk-updates-lang.
Comment 6 Frank Krüger 2018-01-28 15:04:47 UTC
(In reply to Wolfgang Bauer from comment #5)
> And I just checked on my 42.3 system (with KDE:Frameworks5), that message
> *is* translated to german now.
> 
> You probably still use the old translations from bundle-lang-kde-de, which
> of course hasn't been updated yet (because the update is not in Tumbleweed
> yet).
> 
> Uninstall that and the applet should pick up the new/latest translations
> from plasma5-pk-updates-lang.

Removing bundle-lang-kde-de together with the update for plasma5-pk-updates solves the issue. Thx.
Comment 7 Swamp Workflow Management 2018-05-17 17:30:11 UTC
This is an autogenerated message for OBS integration:
This bug (1077851) was mentioned in
https://build.opensuse.org/request/show/610130 42.3 / plasma5-pk-updates
Comment 8 Swamp Workflow Management 2018-05-23 22:15:15 UTC
openSUSE-RU-2018:1408-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1077851,1090375,1093743
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    plasma5-pk-updates-0.3.1-17.1