Bug 1077845 - [Build 20180124][ppc64] openQA test fails in welcome - "Internal error: Failed to load Module 'Lan'"
[Build 20180124][ppc64] openQA test fails in welcome - "Internal error: Faile...
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
PowerPC Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
Jiri Srain
https://openqa.opensuse.org/tests/593...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-27 10:12 UTC by Oliver Kurz
Modified: 2018-02-01 13:47 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-01-27 10:12:12 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64-boot_to_snapshot@ppc64 fails in
[welcome](https://openqa.opensuse.org/tests/593504/modules/welcome/steps/7)
with an error popup and broken network. See the screenshot for details.


## Reproducible

Fails since (at least) Build [20180117](https://openqa.opensuse.org/tests/585117)


## Expected result

Last good: [20180116](https://openqa.opensuse.org/tests/583810) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=ppc64&test=boot_to_snapshot&distri=opensuse&version=Tumbleweed&flavor=DVD&machine=ppc64)
Comment 1 Josef Reidinger 2018-01-29 13:07:56 UTC
this looks like inconsistent snapshot where missing some of new yast modules addapted to new storage-ng.

Dimstar - is it possible that new network is not used together with storage-ng?
Comment 2 Dominique Leuenberger 2018-01-29 13:14:51 UTC
(In reply to Josef Reidinger from comment #1)

> Dimstar - is it possible that new network is not used together with
> storage-ng?

Generally yes, if things failed to build in :PowerPC

The yast2* packages are all inherited from openSUSE:Factory and all built without failure, so those should not be a problem

There is one build failure though in oS:F:PowerPC, that could have quite some side effects:

skelcd-control-openSUSE: https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/skelcd-control-openSUSE/standard/ppc64le (but it looks weird in relation to the yast issue reported here)
Comment 3 Dominique Leuenberger 2018-01-29 13:15:47 UTC
erm - but what strikes me really bad in the screenshot is the reference to ruby2.4.0 - we switched to ruby 2.5!
Comment 4 Josef Reidinger 2018-01-31 15:32:08 UTC
can you please retest it with the latest ppc build? there was some problems with TW on ppc building.
Comment 5 Oliver Kurz 2018-02-01 09:22:35 UTC
openQA does the job of retesting :) You can always check the link to the latest result in the corresponding scenario. However, the latest job as of now is still the same one as originally reported. This means there was no new build since that time for https://build.opensuse.org/project/show/openSUSE:Factory:PowerPC/

Quite some build errors in https://build.opensuse.org/project/monitor/openSUSE:Factory:PowerPC?blocked=0&building=0&dispatching=0&finished=0&scheduled=0&signing=0&succeeded=0
Comment 6 Dominique Leuenberger 2018-02-01 09:30:40 UTC
A new snapshot has just been tagged by ttm-powerpc for testing:

Feb 01 09:26:22 packagelists totest-manager[23094]: totest-manager:443 INFO Updating snapshot 20180131
Comment 7 Oliver Kurz 2018-02-01 13:46:54 UTC
https://openqa.opensuse.org/tests/598043 passed, it's green! I assume we are done here with a consistent state of storage-ng now in openSUSE:Factory:PowerPC as well
Comment 8 Oliver Kurz 2018-02-01 13:47:02 UTC
.