Bug 1077600 - [Build 20180113] openQA test fails in install_and_reboot
[Build 20180113] openQA test fails in install_and_reboot
Status: RESOLVED FIXED
: 1077602 1077605 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
aarch64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dr. Werner Fink
E-mail List
https://openqa.opensuse.org/tests/589...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-25 11:54 UTC by Freek de Kruijf
Modified: 2018-11-21 10:26 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2018-01-25 11:54:34 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-gnome@aarch64 fails in
[install_and_reboot](https://openqa.opensuse.org/tests/589355/modules/install_and_reboot/steps/26)


## Reproducible

Fails since (at least) Build [20180113](https://openqa.opensuse.org/tests/589355) (current job)


## Expected result

Last good: [20180104](https://openqa.opensuse.org/tests/575153) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=aarch64&distri=opensuse&test=gnome&version=Tumbleweed&machine=aarch64&flavor=DVD)

Error message shows an unknown command "clear", which gives a non-zero return code, so the echo does not send the proper string with a zero (0) in it, which makes the test fail.
Comment 1 Chenzi Cao 2018-01-26 07:00:29 UTC
*** Bug 1077605 has been marked as a duplicate of this bug. ***
Comment 2 Chenzi Cao 2018-01-26 07:02:23 UTC
*** Bug 1077602 has been marked as a duplicate of this bug. ***
Comment 3 Dr. Werner Fink 2018-01-26 09:27:31 UTC
AFAICS that is aarch64 only (bug settings corrected) ... if this is true than the question rises if this is an emulated system (VM/qemu-arch64) or a real iron/hardware system based on aarch64 ... next is it could be a gcc problem as well as I had seen last time a lot of build error for aarch64 not only with ncurses but also with other packages I'm maintaining.
Comment 4 Alexander Graf 2018-01-26 10:03:46 UTC
This looks like a missing space key to me. We've had a lot of failures due to lost keys already - with different reasons as to why they went missing.
Comment 5 Freek de Kruijf 2018-01-26 10:06:03 UTC
(In reply to Dr. Werner Fink from comment #3)
> AFAICS that is aarch64 only (bug settings corrected) ... if this is true
> than the question rises if this is an emulated system (VM/qemu-arch64) or a
> real iron/hardware system based on aarch64 ... next is it could be a gcc
> problem as well as I had seen last time a lot of build error for aarch64 not
> only with ncurses but also with other packages I'm maintaining.

On https://build.opensuse.org/package/show/Base:System/ncurses I see you recently fixed something and the build for aarch64 has succeeded. So a reschedule for the OpenQA test might be desirable.
Comment 6 Dr. Werner Fink 2018-01-26 10:11:00 UTC
(In reply to Freek de Kruijf from comment #5)
> (In reply to Dr. Werner Fink from comment #3)
> > AFAICS that is aarch64 only (bug settings corrected) ... if this is true
> > than the question rises if this is an emulated system (VM/qemu-arch64) or a
> > real iron/hardware system based on aarch64 ... next is it could be a gcc
> > problem as well as I had seen last time a lot of build error for aarch64 not
> > only with ncurses but also with other packages I'm maintaining.
> 
> On https://build.opensuse.org/package/show/Base:System/ncurses I see you
> recently fixed something and the build for aarch64 has succeeded. So a
> reschedule for the OpenQA test might be desirable.

This does not fix the missing space key ... right?  Beside this as pacakge maintainer I've no influence on how fast new ncurses will reach Tumbleweed ;)
Comment 7 Freek de Kruijf 2018-01-26 11:38:36 UTC
(In reply to Dr. Werner Fink from comment #6)
> This does not fix the missing space key ... right?  Beside this as pacakge
> maintainer I've no influence on how fast new ncurses will reach Tumbleweed ;)

I don't know. I only noticed that the command clear did not exist, which comes from the ncurses project. The missing space remark comes from Alexander. Was there a missing space in ncurses?
Comment 8 Dr. Werner Fink 2018-01-26 12:14:32 UTC
(In reply to Freek de Kruijf from comment #7)
> (In reply to Dr. Werner Fink from comment #6)
> > This does not fix the missing space key ... right?  Beside this as pacakge
> > maintainer I've no influence on how fast new ncurses will reach Tumbleweed ;)
> 
> I don't know. I only noticed that the command clear did not exist, which
> comes from the ncurses project. The missing space remark comes from
> Alexander. Was there a missing space in ncurses?

The program /usr/bin/clear is explicit part of ncurses-utils, that is if this program would not be build then the build does simply fail .... the missing space key if that there is no keyboard with that key.

In other words, if package ncurses-utils exists on the QA build 20180113 then this is not an error of the package but an error of not be installed on the test scheme for arch64
Comment 9 Alexander Graf 2018-01-26 13:09:09 UTC
The missing "clear" command is not an issue IIUC - it happens on all OpenQA runs. The problem is that the line after was mistyped. Instead of "|" it was typing ">".

See the following log entry in autoinst.txt:

[2018-01-23T14:40:51.0797 CET] [debug] <<< testapi::type_string(string='(/bin/bash -eox pipefail /tmp/scriptXUeAZ.sh ; echo SCRIPT_FINISHEDXUeAZ-$?-)| tee /dev/ttyAMA0
', max_interval=250, wait_screen_changes=0, wait_still_screen=0)

and compare it to the graphical output you see before/after the failure.
Comment 10 Freek de Kruijf 2018-01-26 13:16:01 UTC
(In reply to Alexander Graf from comment #9)
> The missing "clear" command is not an issue IIUC - it happens on all OpenQA
> runs. The problem is that the line after was mistyped. Instead of "|" it was
> typing ">".
> 
> See the following log entry in autoinst.txt:
> 
> [2018-01-23T14:40:51.0797 CET] [debug] <<<
> testapi::type_string(string='(/bin/bash -eox pipefail /tmp/scriptXUeAZ.sh ;
> echo SCRIPT_FINISHEDXUeAZ-$?-)| tee /dev/ttyAMA0
> ', max_interval=250, wait_screen_changes=0, wait_still_screen=0)
> 
> and compare it to the graphical output you see before/after the failure.

OK. So when will there be a reschedule of the test.
Comment 11 Freek de Kruijf 2018-11-21 10:26:56 UTC
Seems to be fixed.