Bug 1077565 - [Build 20180124] openQA test fails in grub_test
[Build 20180124] openQA test fails in grub_test
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Live Medium
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Fabian Vogt
E-mail List
https://openqa.opensuse.org/tests/591...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-25 09:39 UTC by Dominique Leuenberger
Modified: 2018-01-26 10:21 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-25 09:39:14 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde-live_installation@64bit fails in
[grub_test](https://openqa.opensuse.org/tests/591458/modules/grub_test/steps/2)


## Reproducible

Fails since (at least) Build [20180122](https://openqa.opensuse.org/tests/588890)


## Expected result

Last good: [20180121](https://openqa.opensuse.org/tests/588661) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?version=Tumbleweed&flavor=KDE-Live&machine=64bit&arch=x86_64&distri=opensuse&test=kde-live_installation)

When rerunning the test, the failure switches between installer not finishing at all or not rebooting in the end
Comment 1 Fabian Vogt 2018-01-25 10:01:24 UTC
Looks like YaST just froze after switching back to X. No useful information in the logs, needs manual reproduction.
Comment 2 Fabian Vogt 2018-01-25 14:17:23 UTC
I just tried, I am unable to reproduce the issue :-/
Comment 3 Fabian Vogt 2018-01-26 08:59:27 UTC
(In reply to Fabian Vogt from comment #2)
> I just tried, I am unable to reproduce the issue :-/

Seems like openQA can't either, the next snapshot works again: https://openqa.opensuse.org/tests/592566#

It might be an issue with window focus or maybe the FB not updating or just about anything else - hard to tell without a way to reproduce.
Comment 4 Dominique Leuenberger 2018-01-26 10:08:13 UTC
The initial comment said:

When rerunning the test, the failure switches between installer not finishing at all or not rebooting in the end

And I have not yet seen ANY run that rebooted in the end
Comment 5 Fabian Vogt 2018-01-26 10:21:17 UTC
(In reply to Dominique Leuenberger from comment #4)
> The initial comment said:
> 
> When rerunning the test, the failure switches between installer not
> finishing at all or not rebooting in the end

That was a missing needle.

> And I have not yet seen ANY run that rebooted in the end

The net installer does not reboot, which is intentional.