Bug 1077495 - Infinite Recursion at /usr/bin/X11
Infinite Recursion at /usr/bin/X11
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Stefan Dirsch
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-24 22:56 UTC by William Jackson
Modified: 2018-01-27 12:14 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
sndirsch: needinfo? (wtjack3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Jackson 2018-01-24 22:56:04 UTC
The symlink at /usr/bin/X11 points back to /usr/bin, leading to an infinitely recurring directory structure.  Also affects Leap 42.3.
Comment 1 Stefan Dirsch 2018-01-26 11:20:54 UTC
Not again. Why do you believe this is an issue? It's there for compatibily reasons since ages ...
Comment 2 William Jackson 2018-01-26 18:23:02 UTC
I don't really believe that it is an issue.  That symlink isn't there in a few other major distributions I checked, although I've since discovered that Debian has it, so I thought that it had as much of a chance of being something that was overlooked as it did of being something that was there by design.

Would you mind explaining what compatibility issues it's designed to address?
Comment 3 Stefan Dirsch 2018-01-27 12:14:35 UTC
(In reply to William Jackson from comment #2)
> Would you mind explaining what compatibility issues it's designed to address?

Scripts may still consider X binaries like imake in /usr/bin/X11 instead of expecting it in /usr/bin or in $PATH, so things like /usr/bin/X11/imake fail.
Yes, *very* old scripts ...