Bug 1077015 - zypper dup/up on Btrfs consume 100% CPU and freeze desktop
zypper dup/up on Btrfs consume 100% CPU and freeze desktop
Status: RESOLVED DUPLICATE of bug 1032027
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-22 11:13 UTC by Yunhe Guo
Modified: 2018-11-02 06:42 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yunhe Guo 2018-01-22 11:13:06 UTC
When doing zypper dup or zypper up on Btrfs root partition, a Btrfs process will consume 100% CPU and freeze desktop.

Then I have to force shutdown machine by pressing the power button.

When reboot system, it cannot boot into system.

I run rescue system and use 'btrfs check /dev/sda3' to repair Btrfs file system. Then I can boot to my system.

My friend Michael Du has the similar problem with his Tumbleweed system.
Comment 1 Tomáš Chvátal 2018-06-20 07:49:24 UTC
This will probably be kernel issue. Just note that without any logs the kernel team won't be able to fix the issue.
Comment 2 Yunhe Guo 2018-11-02 06:42:30 UTC
There are already other bug reports for the same issue (btrfs-cleaner 100% CPU).

*** This bug has been marked as a duplicate of bug 1032027 ***