Bug 1076912 - Apache2 module installation fails: Undefined method "SetNeededPortsAndProtocols"
Apache2 module installation fails: Undefined method "SetNeededPortsAndProtocols"
Status: RESOLVED DUPLICATE of bug 1076837
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-21 03:03 UTC by Carsten Boeving
Modified: 2018-01-24 08:18 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Boeving 2018-01-21 03:03:47 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Build Identifier: 

Installation of apache2 module "php5" fails in YaST2 with error message:

Internal Error. ...
Details: undefined method `SetNeededPortsAndProtocols` for #<Yast::SuSEFirewalldServiceClass:0x0000000002b12d10>
Did you mean? GetNeededPortsAndProtocols
Caller: /usr/share/YaST2/modules/HttpServer.rb:473:in `Write`


Reproducible: Always

Steps to Reproduce:
1.sudo zypper remove php7
2.sudo yast2
3.Network Services -> HTTP Server
4.Server Modules -> php5 - Toggle service to "Enabled"
5.Finish
6.Install
7.Error message pops up
Actual Results:  
Error message and php5 installation failed

Expected Results:  
php5 installation succeeds

Latest OpenSUSE Tumbleweed installation (20180119), standard KDE install
Comment 1 Imobach Gonzalez Sosa 2018-01-23 15:00:04 UTC
Knut, please, could you have a look?
Comment 2 Knut Alejandro Anderssen González 2018-01-24 08:18:20 UTC
Closing it as duplicate of 1076837

*** This bug has been marked as a duplicate of bug 1076837 ***