Bug 1076837 - [Build 20180117] yast2-http cannot cope with firewalld
[Build 20180117] yast2-http cannot cope with firewalld
Status: RESOLVED FIXED
: 1076912 1077612 1077886 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Knut Alejandro Anderssen González
Jiri Srain
https://openqa.opensuse.org/tests/586...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-19 15:40 UTC by Dominique Leuenberger
Modified: 2022-09-12 10:23 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-19 15:40:59 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
[yast2_http](https://openqa.opensuse.org/tests/586050/modules/yast2_http/steps/29)


## Reproducible

Fails since (at least) Build [20171029](https://openqa.opensuse.org/tests/518687)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&test=yast2_ncurses&version=Tumbleweed&flavor=DVD&machine=64bit)


y2logs can be found at https://openqa.opensuse.org/tests/586050/file/yast2_http-y2logs.tar.bz2
Comment 1 Josef Reidinger 2018-01-19 16:05:57 UTC
knut  please check
Comment 2 Knut Alejandro Anderssen González 2018-01-24 08:17:25 UTC
This is a known issue because of a yet-unfinished feature: Switching from SuSEfirewall2 to firewalld

I'm doing last changes related to the remaining http-server perl code and the new firewalld API (part of this PBI https://trello.com/c/99OkErr6)
Comment 3 Knut Alejandro Anderssen González 2018-01-24 08:18:20 UTC
*** Bug 1076912 has been marked as a duplicate of this bug. ***
Comment 4 Josef Reidinger 2018-01-25 16:52:29 UTC
*** Bug 1077612 has been marked as a duplicate of this bug. ***
Comment 5 Knut Alejandro Anderssen González 2018-01-29 12:27:13 UTC
*** Bug 1077886 has been marked as a duplicate of this bug. ***
Comment 6 Knut Alejandro Anderssen González 2018-03-14 12:23:02 UTC
The service definition is already shipped with the apache2 package so will consider this bug as fixed:

https://build.opensuse.org/package/rdiff/openSUSE:Factory/apache2?linkrev=base&rev=141