Bug 1076650 - xtables-addons: no longer works after kernel update to 4.14.13-1-default
xtables-addons: no longer works after kernel update to 4.14.13-1-default
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-18 18:42 UTC by Arjen de Korte
Modified: 2018-10-18 09:16 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Errors during installation (501 bytes, application/gzip)
2018-01-28 14:29 UTC, Arjen de Korte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arjen de Korte 2018-01-18 18:42:50 UTC
During the installation of xtables-addons-kmp-default, the following is logged:

Aanvullende rpm-uitvoer:
depmod: WARNING: //lib/modules/4.14.13-1-default/extra/xt_condition.ko needs 
unknown symbol (null)
[ repeats many times ]
depmod: WARNING: //lib/modules/4.14.13-1-default/extra/xt_geoip.ko needs unknown symbol (null)
[ repeats many times ]
Warning: /lib/modules/4.14.13-1-default is inconsistent
Warning: weak-updates symlinks might not be created
depmod: WARNING: /lib/modules/4.14.13-1-default/extra/xt_condition.ko needs unknown symbol (null)
[ repeats many times ]
depmod: WARNING: /lib/modules/4.14.13-1-default/extra/xt_geoip.ko needs unknown symbol (null)
[ repeats many times ]
cat: write error: Broken pipe

After the installation, at least the xt_geoip extension can no longer be loaded (I don't use xt_condition, so I don't know about that one).
Comment 1 Arjen de Korte 2018-01-18 20:34:08 UTC
# modprobe --all xt_condition xt_geoip
modprobe: ERROR: could not insert 'xt_condition': Exec format error
modprobe: ERROR: could not insert 'xt_geoip': Exec format error
Comment 2 Arjen de Korte 2018-01-27 21:59:45 UTC
Could it be that the problem is in the toolchain, rather than xtables-addons-kmp? I noticed that over the course of a couple of days, with the same kernel and xtables-addons sources, the module(s) that fail(s) is/are different. Binutils?
Comment 3 Arjen de Korte 2018-01-28 14:29:59 UTC
Created attachment 757820 [details]
Errors during installation

Problems persist after update to kernel 4.14.15 (different modules fail)
Comment 4 Richard Biener 2018-02-01 12:34:42 UTC
Should be a duplicate.

*** This bug has been marked as a duplicate of bug 1076819 ***
Comment 5 Arjen de Korte 2018-02-01 13:16:46 UTC
The changes were accepted to Factory almost a week ago, yet this package is still failing to build correctly. Could this be a similar, but different bug?
Comment 6 Arjen de Korte 2018-03-01 22:24:17 UTC
A month has passed and the problem still exists in the snapshot installed today. Is there anything I can provide in order to help fix this?
Comment 7 Arjen de Korte 2018-03-16 20:49:18 UTC
Problem still exists. Reported again as bug 1085728 as this one seems to be ignored.
Comment 8 Arjen de Korte 2018-10-18 09:16:50 UTC
This problem seems to be resolved. I can no longer reproduce this.