Bug 1076525 - kwebkitpart wrongly firms as version 1.3.4 (was qt4), while being snapshot from master (qt5 dep)
kwebkitpart wrongly firms as version 1.3.4 (was qt4), while being snapshot fr...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-18 09:42 UTC by Friedrich W. H. Kossebau
Modified: 2018-01-20 15:01 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Friedrich W. H. Kossebau 2018-01-18 09:42:59 UTC
The released version of kwebkitpart with the version 1.3.4 is code using Qt4/kdelibs4.

The current kwebkitpart package https://build.opensuse.org/package/view_file/openSUSE:Factory/kwebkitpart/kwebkitpart.spec?expand=1 though uses a snapshot from the master branch of Dec 2016, from after the code was ported to Qt5/KF5 initially. But still sets it a version of 1.3.4.

Problems:
* bugs get reported for wrong version
* Qt4-based kparts and qt5-based kparts are not compatible, talking about versions with users results in confusion when kparts are not found

Please fix the version tag of the package to make clear this is not the released 1.3.4 version, but a snapshot from master.
Comment 1 Wolfgang Bauer 2018-01-18 12:26:32 UTC
I chose to stick to 1.3.4 when I submitted the Qt5/KF5 port because I didn't know what version number an eventual release would get (and at the time I hoped a release would happen soon).

The kpart still identifies itself as version 1.3.0, btw... ;-)

But ok, I'll change it, and maybe update the package to latest git as well. (want to test it first though)
Comment 2 Wolfgang Bauer 2018-01-20 15:01:07 UTC
An updated package is on the way to Factory:
https://build.opensuse.org/request/show/567905