Bug 1076346 - Thinkpad T470s ethernet works in installation but not in OS
Thinkpad T470s ethernet works in installation but not in OS
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-17 09:28 UTC by Markus Zimmermann
Modified: 2018-07-26 04:28 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Zimmermann 2018-01-17 09:28:38 UTC
I installed a fresh Tumbleweed 20180114 on my fresh Thinkpad T470s. The ethernet works during the (network) installation of Tumbleweed but when I boot the system it does not "work" in the OS itself.

With "work" I mean that there is no link/connection. When I use ethtool on the interface the command states there is no link (no carrier, Link detected: no). But when I look at the hardware itself I can see that one LED out of two is green: the hardware detects the cable.

I reseted the interface using the ethtool but this did not work but then I did:

ethtool -s theinterfacename speed 100 duplex full

And the second LED went from nothing to yellow and the interface suddenly worked. 

Please note that when I use the same cable with the Docking Station it works with 1Gbit.
Comment 1 Tomáš Chvátal 2018-06-20 07:54:33 UTC
Probably an issue with HW initialization -> kernel or firmware...
Comment 2 david chang 2018-07-25 08:28:25 UTC
(In reply to Markus Zimmermann from comment #0)
> I installed a fresh Tumbleweed 20180114 on my fresh Thinkpad T470s. The
> ethernet works during the (network) installation of Tumbleweed but when I
> boot the system it does not "work" in the OS itself.
> 
> With "work" I mean that there is no link/connection. When I use ethtool on
> the interface the command states there is no link (no carrier, Link
> detected: no). 

It seems physical layer is not up? Please check up the cable or switch port.

> But when I look at the hardware itself I can see that one LED
> out of two is green: the hardware detects the cable.

What's the link mode of the interface? What about ip link up the interface manually?

> 
> I reseted the interface using the ethtool but this did not work but then I
> did:
> 
> ethtool -s theinterfacename speed 100 duplex full
> 
> And the second LED went from nothing to yellow and the interface suddenly
> worked. 

Or you can try to disable autoneg and set the speed to 1G.

ethtool -s $INTERFACE autoneg off

> Please note that when I use the same cable with the Docking Station it works
> with 1Gbit.

Could you provide provide more detail of the netcard? It'd be useful to provide the dmesg log when issue happening. Thanks!
Comment 3 Markus Zimmermann 2018-07-25 10:46:15 UTC
I just tried with a few scenarios (right-away, rebooting, suspend/resume) an Ethernet cable and the link was up right away with 1GBit. Hence, I cannot reproduce the problem. Maybe this was a.) a problem which occurs only right after a fresh installation or b.) it was fixed a long long time ago.

It looks like that we will receive some new hardware in September. If the problems happens again, I will provide you with the outputs of your mentioned commands.

For now I think we should just close this issue. Anyway, thanks for taking a look. I really do appreciate it!
Comment 4 david chang 2018-07-26 04:28:28 UTC
(In reply to Markus Zimmermann from comment #3)
> I just tried with a few scenarios (right-away, rebooting, suspend/resume) an
> Ethernet cable and the link was up right away with 1GBit. Hence, I cannot
> reproduce the problem. Maybe this was a.) a problem which occurs only right
> after a fresh installation or b.) it was fixed a long long time ago.
> 
> It looks like that we will receive some new hardware in September. If the
> problems happens again, I will provide you with the outputs of your
> mentioned commands.
> 
> For now I think we should just close this issue. Anyway, thanks for taking a
> look. I really do appreciate it!

Thank you for the update.