Bug 1076325 - Mesa or Mesa-drivers build failed for ppc64le on obs-power8-05 worker with "unpacking of archive failed ... cpio: write"
Mesa or Mesa-drivers build failed for ppc64le on obs-power8-05 worker with "u...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
PowerPC Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
https://openqa.opensuse.org/tests/583...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-17 08:31 UTC by Michel Normand
Modified: 2018-06-21 21:36 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
mesa_drivers_obs_ppc64le_failure2.log (137.77 KB, text/x-log)
2018-01-17 15:51 UTC, Michel Normand
Details
mesa_obs_ring1_failure_unpacking.log (32.57 KB, text/x-log)
2018-01-17 16:10 UTC, Michel Normand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-01-17 08:31:49 UTC
[Build 20180116] openQA test fails in first_boot (specific to DESKTOP=kde)

This test is unable to display login prompt

Same problem for RAID10, RAID5,create_hdd_gnome, install_only
that all have DESKTOP=kde

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-RAID10@ppc64le fails in
[first_boot](https://openqa.opensuse.org/tests/583893/modules/first_boot/steps/21)


## Reproducible

Fails since (at least) Build [20180116](https://openqa.opensuse.org/tests/583828)


## Expected result

Last good: [20180114](https://openqa.opensuse.org/tests/582955) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?machine=ppc64le&flavor=DVD&version=Tumbleweed&test=RAID10&distri=opensuse&arch=ppc64le)
Comment 1 Dominique Leuenberger 2018-01-17 13:05:11 UTC
>Same problem for RAID10, RAID5,create_hdd_gnome, install_only
>that all have DESKTOP=kde

create_hdd_gnome hopefully has not DESKTOP-kde set
Comment 2 Dominique Leuenberger 2018-01-17 13:06:01 UTC
My immediate first thought for this kind of problem woult be Mesa/Mesa-drivers split
Comment 3 Dominique Leuenberger 2018-01-17 13:18:10 UTC
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/Mesa-drivers/standard/ppc64le

Package failed to build, with a log ending in:

[  166s] kernel-obs-build-4.14.12-1.3          ########################################
[  166s] error: unpacking of archive failed on file /.build.kernel.kvm;5a5e01c2: cpio: write failed - Inappropriate ioctl for device
[  166s] error: kernel-obs-build-4.14.12-1.3.ppc64le: install failed
[  166s] exit ...
[  166s] 
[  166s] obs-power8-05 failed "build Mesa-drivers.spec" at Tue Jan 16 13:46:55 UTC 2018.
[  166s] 
[  166s] ### VM INTERACTION START ###
[  169s] sysrq: SysRq : Power Off
[  169s] reboot: Power down
[  169s] ### VM INTERACTION END ###
[  169s] 
[  169s] obs-power8-05 failed "build Mesa-drivers.spec" at Tue Jan 16 13:46:59 UTC 2018.
Comment 4 Michel Normand 2018-01-17 15:51:19 UTC
Created attachment 756473 [details]
mesa_drivers_obs_ppc64le_failure2.log

The osc jobhist outputs (1) show failure of Mesa-drivers
with workers obs-power8-05, while no failure for ppc64 with obs-power8-03
  
The two captured failing logs (2)  show same "cpio: write failed" error
but for different archive.
  
=== (1)
===
$xx="Mesa"; arch="ppc64le"; osc jobhist  openSUSE:Factory:PowerPC/${xx} standard ${arch} |tail -n2
time                 package       reason           code   build time  worker
2017-12-02 13:43:55  Mesa          source change    succeeded  28m 10s  obs-power8-04:17
2018-01-16 11:02:21  Mesa          source change    succeeded  10m 58s  obs-power8-04:9
$xx="Mesa-drivers"; arch="ppc64le"; osc jobhist -l100 openSUSE:Factory:PowerPC/${xx} standard ${arch}
time                 package       reason           code   build time  worker
2018-01-16 14:46:59  Mesa-drivers  new build        failed     3m  1s   obs-power8-05:34
2018-01-17 14:25:39  Mesa-drivers  new build        failed     3m  5s   obs-power8-05:22
2018-01-17 14:33:04  Mesa-drivers  new build        failed     2m 40s   obs-power8-05:10
2018-01-17 15:46:25  Mesa-drivers  new build        failed     2m 57s   obs-power8-05:20
$xx="Mesa-drivers"; arch="ppc64"; osc jobhist -l100 openSUSE:Factory:PowerPC/${xx} standard ${arch}
time                 package       reason           code              build time      worker
2018-01-16 15:41:44  Mesa-drivers  new build        succeeded 41m  8s   obs-power8-03:24
===

=== (2)
=== extract mesa_drivers_obs_ppc64le_failure.log at 2018-01-16 14:46:59 (same as comment#3)
[    1s] obs-power8-05 started "build Mesa-drivers.spec" at Tue Jan 16 13:44:11 UTC 2018.
[  157s] error: unpacking of archive failed on file /usr/lib64/libclangStaticAnalyzerCheckers.a;5a5e01c2: cpio: write failed - Inappropriate ioctl for device
[  166s] error: unpacking of archive failed on file /.build.kernel.kvm;5a5e01c2: cpio: write failed - Inappropriate ioctl for device
[  169s] obs-power8-05 failed "build Mesa-drivers.spec" at Tue Jan 16 13:46:59 UTC 2018.
===
=== extract mesa_drivers_obs_ppc64le_failure2.log at 2018-01-17 15:46:25
[    0s] obs-power8-05 started "build Mesa-drivers.spec" at Wed Jan 17 14:43:32 UTC 2018.
[  154s] error: unpacking of archive failed on file /usr/lib64/libclangSema.a;5a5f612e: cpio: write failed - Inappropriate ioctl for device
[  173s] obs-power8-05 failed "build Mesa-drivers.spec" at Wed Jan 17 14:46:25 UTC 2018.
===
Comment 5 Michel Normand 2018-01-17 16:10:09 UTC
Created attachment 756477 [details]
mesa_obs_ring1_failure_unpacking.log

I previously identified a similar "cpio: write" error with Mesa build in Ring1
and that was also on same obs-power8-05 worker

=== (3) extract of mesa_obs_ring1_failure_unpacking.log
[    1s] obs-power8-05 started "build Mesa.spec" at Sun Jan  7 05:03:23 UTC 2018.
[  124s] error: unpacking of archive failed on file /usr/lib64/libclangStaticAnalyzerCheckers.a;5a51aa31: cpio: write 
[  125s] error: unpacking of archive failed on file /usr/lib64/clc/cypress-r600--.bc;5a51aa31: cpio: write
[  125s] error: unpacking of archive failed on file /usr/share/wayland-protocols/unstable/xdg-shell/xdg-shell-unstable-v5.xml;5a51aa31: cpio: write
[  125s] error: unpacking of archive failed on file /usr/bin/fdupes;5a51aa31: cpio: write
[  126s] obs-power8-05 failed "build Mesa.spec" at Sun Jan  7 05:05:27 UTC 2018.
===
=== (4)
[normand@mnow541:~/work]
$osc jobhist openSUSE:Factory:PowerPC:Rings:1-MinimalX/Mesa standard ppc64le 
time                 package      reason           code     build time      worker
2017-12-01 09:04:24  Mesa         new build        failed       2m 23s   obs-power8-05:1
2017-12-02 11:40:08  Mesa         meta change      succeeded   28m 33s   obs-power8-03:5
2017-12-02 13:43:11  Mesa         source change    succeeded   28m 32s   obs-power8-03:8
2017-12-04 02:13:37  Mesa         meta change      unchanged   50m 20s   obs-power8-03:29
2017-12-07 07:28:10  Mesa         meta change      succeeded   35m 49s   obs-power8-04:5
2017-12-11 01:33:59  Mesa         meta change      unchanged   52m 44s   obs-power8-03:8
2017-12-13 21:20:12  Mesa         meta change      succeeded   36m 13s   obs-power8-03:1
2017-12-17 16:57:08  Mesa         meta change      unchanged   39m 23s   obs-power8-04:11
2017-12-20 01:03:21  Mesa         meta change      unchanged   50m 48s   obs-power8-03:17
2017-12-21 22:02:02  Mesa         meta change      unchanged   53m 11s   obs-power8-03:2
2017-12-23 18:41:31  Mesa         meta change      unchanged   55m 24s   obs-power8-03:26
2017-12-30 04:31:41  Mesa         meta change      failed       1m 55s   obs-power8-05:1
2018-01-01 23:34:35  Mesa         meta change      failed       2m 14s   obs-power8-05:20
2018-01-03 04:36:44  Mesa         meta change      unchanged   47m 13s   obs-power8-03:21
2018-01-07 06:05:32  Mesa         meta change      failed       2m 31s   obs-power8-05:19
2018-01-09 14:53:44  Mesa         new build        unchanged   37m 56s   obs-power8-04:10
2018-01-12 18:03:35  Mesa         meta change      failed      15m  8s   obs-power8-05:27
2018-01-16 18:12:16  Mesa         source change    succeeded   14m 41s   obs-power8-03:29
$osc jobhist openSUSE:Factory:PowerPC:Rings:1-MinimalX/Mesa-drivers standard ppc64le
time                 package      reason           code     build time      worker
2018-01-17 07:21:44  Mesa-drivers new build        succeeded   29m 47s   obs-power8-04:20
===
Comment 6 Michel Normand 2018-01-17 16:42:26 UTC
my proposal is to add a _constraints file for Mesa package to have disk size greater that what is used by obs-power8-05 worker.
Comment 7 Michel Normand 2018-01-22 07:51:51 UTC
https://build.opensuse.org/request/show/566887