Bug 1075906 - screenlock crashes
screenlock crashes
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-14 16:02 UTC by Roger Larsson
Modified: 2019-01-16 08:43 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Larsson 2018-01-14 16:02:45 UTC
This computer has two active users, for about one week ago the screenlock has crashed and you are suggested to unlock in a for my wife too complicated way.

thumbleweed kde - will again update to latest to see if problem goes away...
Comment 1 Franck Bui 2018-01-23 13:39:18 UTC
Well I'm wondering how we can help here with a so poor description of the issue.

Please give a better description of your issue and you managed to make it crash.

You can also try to find out some relevant information in the journal.
Comment 2 Roger Larsson 2018-01-23 14:35:14 UTC
It happened every day for a while, now it has not happened in several days!

If it happens again what journal should I look into?
Comment 3 Franck Bui 2018-01-23 14:58:44 UTC
(In reply to Roger Larsson from comment #2)
> It happened every day for a while, now it has not happened in several days!
> 

How does it happen ? 

According to $subject, loginctl crashed... if so can you show the command ? also if it crashes you might have a coredump saved, check it with "coredumpctl".

> If it happens again what journal should I look into?

the output of "journalctl -b"
Comment 4 Roger Larsson 2018-01-24 06:59:43 UTC
big error in my report!

it is the screen lock that crashes
Comment 5 Franck Bui 2018-01-24 07:32:20 UTC
OK then it's not a systemd bug AFAICS.

Re-assigning.
Comment 6 Franck Bui 2018-01-24 07:34:53 UTC
I updated the title given the few information with have currently, so it's quite bad.
Comment 7 Stefan Fent 2018-01-24 11:29:42 UTC
 (In reply to Roger Larsson from comment #2)
> It happened every day for a while, now it has not happened in several days!
> 
> If it happens again what journal should I look into?

I remember having had a similar issue, AFAIR after an update of the displaymanager. logging out and back in solved it.

Maybe that helps identifiying the underlying problem
Comment 8 Andreas Stieger 2018-02-27 11:55:42 UTC
Roger, can you please confirm that the message is as follows:

---
The screen locker is broken and unlocking is not possible anymore. In order to unlock switch to a virtual terminal (e.g. CTRL+ALT+F2), log in and execute the command: 

loginctl unlock-sessions

Afterwards switch back to the running session (CTRL+ALT+F7).
---

If so this is usually a graphic problem, moving category.
Comment 9 Stefan Dirsch 2018-02-27 14:19:25 UTC
Screenlocker crash in KDE sounds more like a KDE bug. Seriously. Reassigning.
Comment 10 Luca Beltrame 2018-02-27 14:29:17 UTC
Reporter: please run in the terminal 

/usr/lib64/libexec/kscreenlocker_greet --testing

or, if you are running a 32 bit system, use this instead:

/usr/lib/libexec/kscreenlocker_greet --testing

then try to unlock the window that opens (the "--testing" switch will ensure it won't lock your actual session).

See if there's any terminal output when the screenlocker crashes.

(For others: it may not necessarily be a bug in KDE software, but this will help pinpointing the cause)
Comment 11 Andreas Stieger 2019-01-14 10:22:08 UTC
No response? KDE team may want to close...
Comment 12 Christophe Giboudeaux 2019-01-16 08:43:54 UTC
No feedback, closing