Bug 1075903 - [Mesa 17.3.2] Some OpenGL applications cause system to freeze
[Mesa 17.3.2] Some OpenGL applications cause system to freeze
Status: RESOLVED DUPLICATE of bug 1075901
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-14 13:46 UTC by Filip Vaverka
Modified: 2018-01-14 17:53 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Vaverka 2018-01-14 13:46:41 UTC
After switching to latest Mesa 17.3.2 (but this seems to hold for anything from 17.3.0) packages from OpenSUSE X11:XOrg repository (https://build.opensuse.org/project/show/X11:XOrg) some OpenGL applications cause system (or at least anything graphics related) to freeze. This happens for example to VisPy based applications, but not OpenGL accelerated KDE Plasma.

Hardware:
- AMD RX Vega 64 (VEGA10 GPU)
- AMD Ryzen R7 1800X

Software:
- OpenSUSE Tumbleweed
- Kernel 4.15.rc7-3.1 from Kernel:/HEAD/standard
- Mesa 17.3.2 (I had to switch from default packages because of Vega GPU)

Symptoms:
Launching some OpenGL based applications causes system to freeze and only hard reset seems to help.
After reboot I can see following errors (using "sudo journalctl -b -1"):

-- Logs begin at Mon 2017-07-24 18:28:06 CEST, end at Sun 2018-01-14 14:38:07 CET. --
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe07ee000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe0e2e000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe1037000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe0a01000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe0c2b000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fe123a000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x0000003fdef18000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x000000402ccec000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x000000402cce9000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x0050113D
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0:   at page 0x000000402cced000 from 27
Jan 14 13:07:10 Filip kernel: amdgpu 0000:0d:00.0: [gfxhub] VMC page fault (src_id:0 ring:158 vm_id:5 pas_id:0)
Jan 14 13:07:10 Filip kernel: gmc_v9_0_process_interrupt: 35 callbacks suppressed

Possible causes:
It seems like this problem might be related to LLVM 5 bug discovered on https://bugs.freedesktop.org/show_bug.cgi?id=104192 and fixed in https://reviews.llvm.org/rL320466. Assuming affected version of LLVM is being used.
Comment 1 Stefan Dirsch 2018-01-14 17:53:17 UTC
dup

*** This bug has been marked as a duplicate of bug 1075901 ***