Bug 1075883 - rust-std does not get updated together with rust
rust-std does not get updated together with rust
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Luke Jones
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-13 18:25 UTC by Matthias Brugger
Modified: 2021-07-12 04:35 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Brugger 2018-01-13 18:25:17 UTC
I just updated rust to the newest version (1.22.1) but rust-std didn't get updated. This led to a not working rustc. Compiling a simple hello world crashed with:

mbrugger@ziggy:~/src/rust/projects/hello_world> rustc main.rs 
error[E0514]: found crate `std` compiled by an incompatible version of rustc
  |
  = help: please recompile that crate using this compiler (rustc 1.22.1)
  = note: crate `std` path #1: /usr/lib/rustlib/x86_64-unknown-linux-gnu/lib/libstd_unicode-24d077784ff294bb.rlib compiled by "rustc 1.21.0"
  = note: crate `std` path #2: /usr/lib/rustlib/x86_64-unknown-linux-gnu/lib/libstd-93d5378bceaf3688.rlib compiled by "rustc 1.21.0"
  = note: crate `std` path #3: /usr/lib/rustlib/x86_64-unknown-linux-gnu/lib/libstd-93d5378bceaf3688.so compiled by "rustc 1.21.0"

error: aborting due to previous error


Solution:
After updating rust-std by hand, I was able to compile the hello world.

Expected behaviour:
rust-std should be always updated whenever you update rust
Comment 1 Luke Jones 2018-01-22 07:08:38 UTC
Awaiting build and push to factory.
Comment 2 Swamp Workflow Management 2018-01-23 09:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1075883) was mentioned in
https://build.opensuse.org/request/show/568496 Factory:Staging:O / rust
Comment 3 Andreas Stieger 2018-04-23 21:44:52 UTC
I guess this is fixed now
Comment 4 Swamp Workflow Management 2018-04-24 01:19:10 UTC
openSUSE-RU-2018:1055-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1030232,1075883
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    cargo-0.24.0-2.3.1, rust-1.23.0-2.3.1