Bug 1075879 - Anki desktop application doesn't work
Anki desktop application doesn't work
Status: NEW
: 1081552 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Jan Hilberath
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-13 15:25 UTC by andranique a.
Modified: 2020-04-12 13:35 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andranique a. 2018-01-13 15:25:17 UTC
This is the issue after anki command:
user@linux:~> anki
Traceback (most recent call last):
  File "/usr/bin/anki", line 5, in <module>
    import aqt
  File "/usr/share/anki/aqt/__init__.py", line 12, in <module> 
    from aqt.qt import * 
  File "/usr/share/anki/aqt/qt.py", line 22, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebView, QWebSettings
ImportError: No module named QtWebKit

Here are the depends on my system (I use Education repo to install anki):

Installed Version
Version:             2.0.47-1.4
Provides:            application()
                     appdata()
                     appdata(anki.appdata.xml)
                     application(anki.desktop)
                     mimehandler(application/x-anki)
                     mimehandler(application/x-apkg)
                     anki = 2.0.47-1.4
Prerequires:         /bin/sh
                     /bin/sh
Requires:           /usr/bin/env
                    python-qt4
                    python-sip
                    python-httplib2
                    python-beautifulsoup
                    python-send2trash
                    rpmlib(CompressedFileNames) <= 3.0.4-1
                    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
                    rpmlib(PayloadIsXz) <= 5.2-1
                    /bin/sh
                    /bin/sh
Suggests:           sox
                    MPlayer
                    lame

These packages and libs are not found in my repos:

python-httplib2
python-send2trash
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


libqt4-x11,libQtWebKit4, python2-qt4 are installed on my system.

Also there was upgrade info on Anki website that possibly can explain this issue
https://apps.ankiweb.net/docs/beta.html
Comment 1 Stelian Ionescu 2018-06-06 21:53:31 UTC
*** Bug 1081552 has been marked as a duplicate of this bug. ***
Comment 2 david chang 2018-12-11 02:37:51 UTC
I encounter the same issue with Leap15.

dchang@linux-kyyb:~> anki
Traceback (most recent call last):
  File "/usr/bin/anki", line 5, in <module>
    import aqt
  File "/usr/share/anki/aqt/__init__.py", line 12, in <module>
    from aqt.qt import *
  File "/usr/share/anki/aqt/qt.py", line 22, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebView, QWebSettings
ImportError: No module named QtWebKit

dchang@linux-kyyb:~> rpm -qi anki
Name        : anki
Version     : 2.0.47
Release     : lp150.1.5
Comment 3 Daniel Noga 2020-04-12 13:35:06 UTC
More than two years after report, still not fixed. Leap 15.1
Comment 4 Daniel Noga 2020-04-12 13:35:50 UTC
More than two years after report, still not fixed. Leap 15.1