Bug 1075802 - skelcd-control-CaaSP fails to build in SLE staging because is not openSUSE and is not susecaasp
skelcd-control-CaaSP fails to build in SLE staging because is not openSUSE an...
Status: RESOLVED FIXED
: 1075783 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-12 12:54 UTC by Richard Brown
Modified: 2018-11-07 09:13 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Brown 2018-01-12 12:54:28 UTC
# PREAMBLE

The YaST team have set up their CI in a way that prohibits any contribution to any openSUSE YaST package unless there is a bug or FATE reference

This includes control file changes.

This is contrary to the principles of "factory first" which exist to make most use of openSUSE's broader contributions, contributions which _should_ very often be happening without a bug reference or FATE entry. (After all, the majority of stuff going on in openSUSE _should_ be something other than fixing bugs or doing SUSE-specific features)

In order to work around this anti-contributor behaviour, I will now be creating bugs with this preamble and using them whenever I contribute to any YaST-team managed package. 

Below provides a brief description of the feature, or package, or other new upstream functionality being introduced that facilitated this change in a YaST-team managed package.

# ISSUE
skelcd-control-CaaSP fails to build in SLE staging because is not openSUSE and is not susecaasp
Comment 1 Frederic Crozat 2018-01-12 12:59:05 UTC
*** Bug 1075783 has been marked as a duplicate of this bug. ***
Comment 2 Josef Reidinger 2018-01-15 07:51:17 UTC
Richard - can you please at least point to failed build? so bug have at least some value for us? Or if you want to fix it yourself, please reassign to yourself,
Thanks
Comment 3 Richard Brown 2018-01-15 09:08:17 UTC
(In reply to Josef Reidinger from comment #2)
> Richard - can you please at least point to failed build? so bug have at
> least some value for us? Or if you want to fix it yourself, please reassign
> to yourself,
> Thanks

Stagings are transient - so no I cannot

This bug has no real value, as the PREAMBLE states it was created purely for the purpose of getting the below PR accepted

https://github.com/yast/skelcd-control-CAASP/pull/61
Comment 4 Josef Reidinger 2018-01-17 14:18:26 UTC
pr merged, so lets close it. BTW next time you can assign it to yourself, so we do not need to sort it :)