Bug 1075690 - Krusader: right-click actions create a file and a directory do not
Krusader: right-click actions create a file and a directory do not
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 42.3
All Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-11 22:18 UTC by Kacper Pluta
Modified: 2018-01-20 17:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kacper Pluta 2018-01-11 22:18:12 UTC
The right click actions Create New -> Folder... and Create New-> Text file... does not work.

To reproduce:

1. Run krusader
2. Right click in a folder
3. Navigate to "Create New"
4a. Click "Folder..." option
4b. Click "Text file..." option
Comment 1 Paul Tannington 2018-01-12 17:34:29 UTC
Krusader 2.6.0 (current for 42.3) has this bug:

https://bugs.kde.org/show_bug.cgi?id=383544 

I believe that is what you are seeing.
Comment 2 Kacper Pluta 2018-01-12 17:36:41 UTC
(In reply to Paul Tannington from comment #1)
> Krusader 2.6.0 (current for 42.3) has this bug:
> 
> https://bugs.kde.org/show_bug.cgi?id=383544 
> 
> I believe that is what you are seeing.

Yes it looks like it is this. Could we get the patch for this prolem, please?
Comment 3 Wolfgang Bauer 2018-01-12 20:04:03 UTC
(In reply to Kacper Pluta from comment #2)
> Yes it looks like it is this. Could we get the patch for this prolem, please?

I backported the fix to 2.6.0 and submitted it to KDE:Extra:
https://build.opensuse.org/request/show/563928
Will submit an update for 42.3 as well.

But just to be clear: the problem only exist if you right-click on the '..' entry, it should work fine everywhere else.
Comment 4 Paul Tannington 2018-01-13 12:58:11 UTC
(In reply to Wolfgang Bauer from comment #3)

Appreciate the backport :)

> But just to be clear: the problem only exist if you right-click on the '..'
> entry, it should work fine everywhere else.

The annoyance was greatest when you had an empty directory and ".." can't be deselected.
Comment 5 Wolfgang Bauer 2018-01-13 13:04:44 UTC
(In reply to Paul Tannington from comment #4)
> (In reply to Wolfgang Bauer from comment #3)
> 
> Appreciate the backport :)
> 

You're welcome.

> > But just to be clear: the problem only exist if you right-click on the '..'
> > entry, it should work fine everywhere else.
> 
> The annoyance was greatest when you had an empty directory and ".." can't be
> deselected.

I see.
Yes, that case would indeed be problematic...
Comment 6 Wolfgang Bauer 2018-01-15 14:35:15 UTC
Update submitted for Leap 42.3:
https://build.opensuse.org/request/show/565789
(42.2's krusader 2.5.0 seems not to be affected...)

Of course you can also install it from KDE:Extra if you want, where it will always be updated to newer versions too when they get released.
Comment 7 Swamp Workflow Management 2018-01-20 17:09:11 UTC
openSUSE-RU-2018:0147-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1075690
CVE References: 
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    krusader-2.6.0-5.1
Comment 8 Swamp Workflow Management 2018-01-20 17:15:32 UTC
openSUSE-RU-2018:0157-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1075690
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    krusader-2.6.0-3.1
Comment 9 Wolfgang Bauer 2018-01-20 17:26:33 UTC
Update released.