Bug 1075581 - some rubygem based rpms does not install gem.build_complete file
some rubygem based rpms does not install gem.build_complete file
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Ruby
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ruby Devel
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-11 11:29 UTC by Jordi Massaguer
Modified: 2018-01-11 13:04 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordi Massaguer 2018-01-11 11:29:51 UTC
We found this issue with native gems such as nokogiri when building portus with ruby2.4:

https://build.opensuse.org/package/show/Virtualization:containers:Portus/portus

This is a known issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1176450

IIUC, we need to update the ruby macros in the ruby-common package to install the gem.build_complete file.

See the this spec file as an example:

https://bodhi.fedoraproject.org/updates/rubygem-pam-1.5.4-20.fc21
Comment 1 Jordi Massaguer 2018-01-11 12:20:15 UTC
(In reply to Jordi Massaguer from comment #0)
> We found this issue with native gems such as nokogiri when building portus
> with ruby2.4:
> 
> https://build.opensuse.org/package/show/Virtualization:containers:Portus/
> portus
> 
> This is a known issue:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1176450
> 
> IIUC, we need to update the ruby macros in the ruby-common package to
> install the gem.build_complete file.
> 
> See the this spec file as an example:
> 
> https://bodhi.fedoraproject.org/updates/rubygem-pam-1.5.4-20.fc21

I just did a quick test and seems that the file is actually there for nokogiri:

rpm -qlp ruby2.4-rubygem-nokogiri-1.8.1-2.7.x86_64.rpm | grep gem.build_complete
/usr/lib64/ruby/gems/2.4.0/extensions/x86_64-linux/2.4.0/nokogiri-1.8.1/gem.build_complete

So the problem must be something else...
Comment 2 Jordi Massaguer 2018-01-11 13:04:26 UTC
(In reply to Jordi Massaguer from comment #1)
> (In reply to Jordi Massaguer from comment #0)
> > We found this issue with native gems such as nokogiri when building portus
> > with ruby2.4:
> > 
> > https://build.opensuse.org/package/show/Virtualization:containers:Portus/
> > portus
> > 
> > This is a known issue:
> > 
> > https://bugzilla.redhat.com/show_bug.cgi?id=1176450
> > 
> > IIUC, we need to update the ruby macros in the ruby-common package to
> > install the gem.build_complete file.
> > 
> > See the this spec file as an example:
> > 
> > https://bodhi.fedoraproject.org/updates/rubygem-pam-1.5.4-20.fc21
> 
> I just did a quick test and seems that the file is actually there for
> nokogiri:
> 
> rpm -qlp ruby2.4-rubygem-nokogiri-1.8.1-2.7.x86_64.rpm | grep
> gem.build_complete
> /usr/lib64/ruby/gems/2.4.0/extensions/x86_64-linux/2.4.0/nokogiri-1.8.1/gem.
> build_complete
> 
> So the problem must be something else...

https://github.com/SUSE/Portus/blob/master/packaging/suse/portus.spec.in#L133

We are removing empty files . So this is not a bug in ruby. Sorry for the noise. Closing...